算法复习——欧拉函数(poj3090)

Posted AseanA

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了算法复习——欧拉函数(poj3090)相关的知识,希望对你有一定的参考价值。

题目:

Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

技术分享

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

题解:

欧拉函数模板题。

心得:

感觉欧拉函数稍微考得隐晦点的就是可视点问题了···嗯就这样

代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<ctime>
#include<cstring>
#include<string>
#include<algorithm>
#include<cctype>
using namespace std;
const int N=1006;
int phi[N],sum[N],n;
void pre()
{
  for(int i=1;i<N;i++)
    phi[i]=i;
  for(int i=2;i<N;i++)  
    if(phi[i]==i)
      for(int j=i;j<N;j+=i)
        phi[j]=phi[j]*(i-1)/i;
  for(int i=2;i<N;i++)
    sum[i]=phi[i]+sum[i-1];
}
int main()
{  
  //freopen("a.in","r",stdin);
  pre();
  scanf("%d",&n);
  for(int i=1;i<=n;i++)
  {
    int k;
    scanf("%d",&k);
    cout<<i<<" "<<k<<" "<<sum[k]*2+3<<endl;
  }
  return 0;
}

 

以上是关于算法复习——欧拉函数(poj3090)的主要内容,如果未能解决你的问题,请参考以下文章

POJ3090(SummerTrainingDay04-M 欧拉函数)

poj3090 Visible Lattice Points [欧拉函数]

POJ_3090 Visible Lattice Points 欧拉函数 + 递推

POJ 3090 Visible Lattice Points | 其实是欧拉函数

POJ3090 Visible Lattice Points

[poj] 3090 Visible Lattice Points