POJ 1163 数塔 — 基础DP

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 1163 数塔 — 基础DP相关的知识,希望对你有一定的参考价值。

The Triangle

Time Limit: 1000 MS Memory Limit: 10000 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

Description

 

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;

int a[105][105];

int dp[105][105];

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {

        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=i;j++)
            {
                scanf("%d",&a[i][j]);
            }
        }

        dp[1][1]=a[1][1];

        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                dp[i][j]=a[i][j]+max(dp[i-1][j],dp[i-1][j-1]);
                      ///当i不变时,将j列遍历,依次赋给相应的dp[i][j];之后会在下一次
                      ///遍历时再利用max(dp[i-1][j],dp[i-1][j-1])选取max值,直到找到目标
            }
        }
        int res=-999;
        for(int i=1;i<=n;i++)
        {
            res=max(res,dp[n][i]);
        }
        printf("%d\n",res);

    }

    return 0;
}

 

以上是关于POJ 1163 数塔 — 基础DP的主要内容,如果未能解决你的问题,请参考以下文章

poj1163 - DP递推递归写法

poj 1163 The Triangle(dp)

POJ 1163 The Triangle DP题解

POJ-1163-The Triangle

POJ 1163&amp;&amp; 3176 The Triangle(DP)

POJ 1163 数字三角形