Problem A: 分数类的输出
Posted TogetherLaugh
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Problem A: 分数类的输出相关的知识,希望对你有一定的参考价值。
Description
Input
Output
Sample Input
Sample Output
HINT
Append Code
#include<iostream>
#include<iomanip>
using namespace std;
int gcd(int a,int b) //辗转相除法;大除以小
{
return b==0?a:gcd(b,a%b);//分母为零不能继续
}
class Fract
{
private:
int x,y;
public:
Fract(int a=0,int b=0):x(a),y(b)
{
int flager=1;
if(y<0)
{
y=-y;
x=-x;
}
if(x<0)
{
flager=-1;
x=-x;
}
int flag=gcd(max(x,y),min(x,y));//max min,节约
x/=flag;
y/=flag;
if(flager==-1)//前方输出
x=-x;
}
void show()
{
if(x==0||y==1)
cout<<x<<endl;
else
cout<<x<<‘/‘<<y<<endl;
}
};
#include <cstdio>
int main()
{
int n, m;
while(cin >> n >> m)
{
Fract fr(n, m);
fr.show();
}
}
以上是关于Problem A: 分数类的输出的主要内容,如果未能解决你的问题,请参考以下文章