1027. Colors in Mars (20)

Posted 一只菜鸡

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1027. Colors in Mars (20)相关的知识,希望对你有一定的参考价值。

1027. Colors in Mars (20)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

 

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input

15 43 71

Sample Output

#123456

 

注意:输入为 0 0 0时的输出

#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
#include <stack>  
using namespace std;


int main() {
    int RGB[3];
    cin >> RGB[0] >> RGB[1] >> RGB[2];
    cout << "#";
    int cnt = 0;
    for (int i = 0; i < 3; i++)
    {
        stack<int > s;
        if (RGB[i] < 13)
            cout << "0";
        do
        {
            int temp = RGB[i] % 13;
            s.push(temp);
            RGB[i] /= 13;
            cnt++;
        } while ((RGB[i] != 0));
        while (!s.empty())
        {
            int t = s.top();
            s.pop();
            switch (t)
            {
            case 0:cout << "0"; break;
            case 1:cout << "1"; break;
            case 2:cout << "2"; break;
            case 3:cout << "3"; break;
            case 4:cout << "4"; break;
            case 5:cout << "5"; break;
            case 6:cout << "6"; break;
            case 7:cout << "7"; break;
            case 8:cout << "8"; break;
            case 9:cout << "9"; break;
            case 10:cout << "A"; break;
            case 11:cout << "B"; break;
            case 12:cout << "C"; break;
            default:break;
            }
        }
    }




    system("pause");
    return 0;
}

 

以上是关于1027. Colors in Mars (20)的主要内容,如果未能解决你的问题,请参考以下文章

1027. Colors in Mars (20)

1027 Colors in Mars (20 分)进制转换

1027 Colors in Mars (20分)

1027 Colors in Mars (20分)

PAT 甲级 1027 Colors in Mars (20 分)

PAT 甲级 1027 Colors in Mars (20 分)(简单,进制转换)