P4812 D’s problem(d)

Posted Nico&11101001

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了P4812 D’s problem(d)相关的知识,希望对你有一定的参考价值。

P4812 D’s problem(d)From: admin
时间: 1000ms / 空间: 65536KiB / Java类名: Main

背景

NOIP春季系列课程

描述

小D是一名魔法师,它最喜欢干的事就是批判记者了。

这次记者招待会上,记者对于小D的数学很好奇。于是小D找了个方法把记者批判了一番。

它对记者抛出了这么一个问题:我有一个长为n的01序列,你能否找到一个位置x,使得1~x中的1的个数与x+1~n中的0的个数相等呢?

记者们表示这样的x可能有多个,因此记者回答了最小的满足要求的x。当不存在这样的x时,记者们回答了n+1。

现在小D忘了记者回答的是什么,因此它来求助你。

输入格式

一行一个01序列 

输出格式

一个数表示答案。

 

输入样例

01100

 

输出样例

3

备注

数据范围

对于30%的数据n<=1000。

对于100%的数据n<=100000。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
using namespace std;
char a[100002];
int main()
{
    int m;
    int tot0=0,tot1=0;
    scanf("%s",&a);
    m=strlen(a);
    for(int i=0;i<m;i++)
    {
        if(a[i]==0)tot0++;
    }
    for(int i=0;i<m;i++)
    {
        if(a[i]==1)tot1++;if(a[i]==0)tot0--;
        if(tot0==tot1)
        {
        printf("%d",i+1);
        return 0;    
        }
    }
    printf("%d",m+1);
    return 0;
}

 

以上是关于P4812 D’s problem(d)的主要内容,如果未能解决你的问题,请参考以下文章

poj2480 Longge's problem

Problem S: 零起点学算法14——三位数反转

UVa 11490 Just Another Problem

HDU 5688 Problem D map

poj 2480 Longge&#39;s problem 积性函数性质+欧拉函数

Problem I: 零起点学算法30——输出四位完全平方数