杭电1001

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了杭电1001相关的知识,希望对你有一定的参考价值。

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

 

Input
The input will consist of a series of integers n, one integer per line.
 

 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

 

Sample Input
1 100
 

 

Sample Output
1 5050
 
这一题主要是考研C语言初学者如何使用循环结构,当然还要注意followed by a blank line这句话,不然是ac不了的
 

#include<stdio.h>
int main()
{
  int n,i,a;
  while(scanf("%d",&n)!=EOF)
  {
   a=0;
   for(i=1;i<=n;i++)
    a=a+i;
   printf("%d\n\n",a);// 要多空出一行
  }
  return 0;
}

  

 

以上是关于杭电1001的主要内容,如果未能解决你的问题,请参考以下文章

杭电 1001

杭电oj-1001

杭电OJ 1001

杭电OJ 1001

杭电oj1002,,做完留一下记录(c)

杭电2018多校第六场(2018 Multi-University Training Contest 6) 1001.oval-and-rectangle (HDU6362)-数学期望微积分(示例代(