1058. 选择题(20)

Posted 一只菜鸡

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1058. 选择题(20)相关的知识,希望对你有一定的参考价值。

1058. 选择题(20)

批改多选题是比较麻烦的事情,本题就请你写个程序帮助老师批改多选题,并且指出哪道题错的人最多。

输入格式:

输入在第一行给出两个正整数N(<=1000)和M(<=100),分别是学生人数和多选题的个数。随后M行,每行顺次给出一道题的满分值(不超过5的正整数)、选项个数(不少于2且不超过5的正整数)、正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母a开始顺次排列。各项间以1个空格分隔。最后N行,每行给出一个学生的答题情况,其每题答案格式为“(选中的选项个数 选项1 ……)”,按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。

输出格式:

按照输入的顺序给出每个学生的得分,每个分数占一行。注意判题时只有选择全部正确才能得到该题的分数。最后一行输出错得最多的题目的错误次数和编号(题目按照输入的顺序从1开始编号)。如果有并列,则按编号递增顺序输出。数字间用空格分隔,行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行输出“Too simple”。

输入样例:

3 4 
3 4 2 a c
2 5 1 b
5 3 2 b c
1 5 4 a b d e
(2 a c) (2 b d) (2 a c) (3 a b e)
(2 a c) (1 b) (2 a b) (4 a b d e)
(2 b d) (1 e) (2 b c) (4 a b c d)

输出样例:

3
6
5
2 2 3 4

这题没写,代码参考自网络
#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <set>
using namespace std;


int main()
{
    int stunum, quesnum;
    scanf("%d%d", &stunum, &quesnum);
    vector<int>score(quesnum);
    vector<int>wrongCnt(quesnum);
    vector<set<char>> right(quesnum);
    for (int i = 0; i < quesnum; i++)
    {
        int temp1, temp2;
        scanf("%d%d%d", &score[i], &temp1, &temp2);

        for (int j = 0; j < temp2; j++)
        {
            char c;
            scanf(" %c",&c);
            right[i].insert(c);
        }
    }

    for (int i = 0; i < stunum; i++)
    {
        int chengji = 0;
        getchar();
        for (int j = 0; j < quesnum; j++)
        {
            int k;
            /*string input;
            set<char>daan;
            scanf("%s", input);
            for (string::iterator it = input.begin(); it != input.end(); it++)
            {
                if (*it == ‘a‘) daan.insert(‘a‘);
                else if (*it == ‘b‘) daan.insert(‘b‘);
                else if (*it == ‘c‘) daan.insert(‘c‘);
                else if (*it == ‘d‘) daan.insert(‘d‘);
                else if (*it == ‘e‘) daan.insert(‘e‘);
            }
            if (daan == right[j])
                chengji += score[j];
            else
                wrongCnt[j]++;*/
                
                
            if (j != 0) scanf(" ");
            scanf("(%d", &k);
            set<char> st;
            char c;
            for (int l = 0; l < k; l++) {
                scanf(" %c", &c);
                st.insert(c);
            }
            scanf(")");
            if (st == right[j]) {
                chengji += score[j];
            }
            else {
                wrongCnt[j]++;
            }

        }
        cout << chengji << endl;
    }




    int max = 0;
    for (int i = 0; i < quesnum; i++)
    {
        if (wrongCnt[i] > max)
        {
            max = wrongCnt[i];
        }
    }
    if (max == 0)
        cout <<"Too simple"<< endl;
    else
    {
        cout << max;
        for (int i = 0; i < quesnum; i++)
        {
            if (wrongCnt[i] == max)
                cout << " " << i + 1;
        }
    }



    system("pause");
    return 0;
}

 



以上是关于1058. 选择题(20)的主要内容,如果未能解决你的问题,请参考以下文章

struct应用_1058 选择题 (20 分)

1058. 选择题(20)

P1058 选择题

1058 选择题

1058 A+B in Hogwarts (20 分)

1058 A+B in Hogwarts (20分)