1067. 试密码(20)

Posted 一只菜鸡

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1067. 试密码(20)相关的知识,希望对你有一定的参考价值。

1067. 试密码(20)

当你试图登录某个系统却忘了密码时,系统一般只会允许你尝试有限多次,当超出允许次数时,账号就会被锁死。本题就请你实现这个小功能。

输入格式:

输入在第一行给出一个密码(长度不超过20的、不包含空格、Tab、回车的非空字符串)和一个正整数N(<= 10),分别是正确的密码和系统允许尝试的次数。随后每行给出一个以回车结束的非空字符串,是用户尝试输入的密码。输入保证至少有一次尝试。当读到一行只有单个#字符时,输入结束,并且这一行不是用户的输入。

输出格式:

对用户的每个输入,如果是正确的密码且尝试次数不超过N,则在一行中输出“Welcome in”,并结束程序;如果是错误的,则在一行中按格式输出“Wrong password: 用户输入的错误密码”;当错误尝试达到N次时,再输出一行“Account locked”,并结束程序。

输入样例1:

Correct%pw 3
correct%pw
[email protected]
whatisthepassword!
Correct%pw
#

输出样例1:

Wrong password: correct%pw
Wrong password: [email protected]
Wrong password: whatisthepassword!
Account locked

输入样例2:

[email protected] 3
[email protected]
[email protected]
[email protected]
try again
#

输出样例2:

Wrong password: [email protected]
Wrong password: [email protected]
Welcome in
#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
using namespace std;


int main()
{
    string ans,temp;
    int n,cnt=0;
    cin >> ans >> n;
    vector<string> input(n);
    getchar();
    while (1)
    {
        getline(cin, temp);
        if (temp != "#") cnt++;
        else break;
        if (cnt <= n&&temp == ans)
        {
            cout << "Welcome in"<<endl;
            break;
        }
        else if (cnt <= n&&temp != ans)
        {
            cout << "Wrong password: " << temp << endl;
            if (cnt == n)
            {
                cout << "Account locked" << endl; break;
            }
        }
    }
    
    
    
    
    system("pause");
    return 0;
}

 



以上是关于1067. 试密码(20)的主要内容,如果未能解决你的问题,请参考以下文章

1067 试密码 (20 分)

PTA乙级 (1067 试密码 (20分))

PAT 1067. 试密码(20)

PAT乙级1067 试密码 (20 分)

PAT 1067. 试密码

1067 试密码