1016. 部分A+B (15)

Posted 一只菜鸡

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1016. 部分A+B (15)相关的知识,希望对你有一定的参考价值。

1016. 部分A+B (15)

正整数A的“DA(为1位整数)部分”定义为由A中所有DA组成的新整数PA。例如:给定A = 3862767,DA = 6,则A的“6部分”PA是66,因为A中有2个6。

现给定A、DA、B、DB,请编写程序计算PA + PB

输入格式:

输入在一行中依次给出A、DA、B、DB,中间以空格分隔,其中0 < A, B < 1010

输出格式:

在一行中输出PA + PB的值。

输入样例1:

3862767 6 13530293 3

输出样例1:

399

输入样例2:

3862767 1 13530293 8

输出样例2:

0

#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>

using namespace std;

int main()
{
    string a,b;
    char da, db;
    int count_a=0, count_b=0;
    int pa=0, pb=0;
    cin >> a >> da >> b >> db;
    for (string::iterator it = a.begin(); it != a.end(); it++)
    {
        if (*it == da)
            count_a++;
    }
    for (string::iterator it = b.begin(); it != b.end(); it++)
    {
        if (*it == db)
            count_b++;
    }
    for (int i = 1; i <= count_a; i++)
    {
        pa = pa*10+da-0;
    }
    for (int i = 1; i <= count_b; i++)
    {
        pb = pb * 10 + db - 0;
    }


    cout << pa + pb;
    system("pause");
    return 0;
}

 



以上是关于1016. 部分A+B (15)的主要内容,如果未能解决你的问题,请参考以下文章

1016. 部分A+B (15)

1016. 部分A+B (15)

B1016 部分A+B (15分)

1016. 部分A+B (15)

1016. 部分A+B (15)

1016. 部分A+B (15)