UVA - 12230 Crossing Rivers (期望)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA - 12230 Crossing Rivers (期望)相关的知识,希望对你有一定的参考价值。

Description

技术分享

You live in a village but work in another village. You decided to follow the straight path between your house (A) and the working place (B), but there are several rivers you need to cross. Assume B is to the right of A, and all the rivers lie between them.

Fortunately, there is one ``automatic" boat moving smoothly in each river. When you arrive the left bank of a river, just wait for the boat, then go with it. You‘re so slim that carrying you does not change the speed of any boat.

Days and days after, you came up with the following question: assume each boat is independently placed at random at time 0, what is the expected time to reach B from A?

Your walking speed is always 1.

To be more precise, for a river of length L, the distance of the boat (which could be regarded as a mathematical point) to the left bank at time 0 is uniformly chosen from interval [0, L], and the boat is equally like to be moving left or right, if it‘s not precisely at the river bank.

Input 

There will be at most 10 test cases. Each case begins with two integers n and D, where n(0技术分享n技术分享10) is the number of rivers between A and B, D(1技术分享D技术分享1000) is the distance from A to B. Each of the following n lines describes a river with 3 integers: p, L and v (0技术分享p < D, 0 < L技术分享D, 1技术分享v技术分享100). p is the distance from A to the left bank of this river, L is the length of this river, v is the speed of the boat on this river. It is guaranteed that rivers lie between A and B, and they don‘t overlap. The last test case is followed by n = D = 0, which should not be processed.

Output 

For each test case, print the case number and the expected time, rounded to 3 digits after the decimal point.

Print a blank line after the output of each test case.

Sample Input 

1 1 
0 1 2
0 1 
0 0

Sample Output 

Case 1: 1.000 

Case 2: 1.000
题意:给你A和B的距离。以及途中n条河的信息。问你从A到B的期望
思路:我们单纯算过河时间的话,最快的是l/v,最慢的可能是3l/v,期间的时间是线性的,所以期望就是4l/2v=2l/v
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;

int n;
double p, l, v, d;

int main() {
	int cas = 1;
	while (scanf("%d%lf", &n, &d) != EOF && n+d) {
		while (n--) {
			scanf("%lf%lf%lf", &p, &l, &v);
			d = d - l + l * 2 / v;
		}
		printf("Case %d: %.3lf\n\n", cas++, d);
	}
	return 0;
}

 


以上是关于UVA - 12230 Crossing Rivers (期望)的主要内容,如果未能解决你的问题,请参考以下文章

Uva12230Crossing Rivers (数学期望)

『UVA 12230』Crossing Rivers (简单期望)

uva 12230 Crossing Rivers

UVa 12230 - Crossing Rivers(数学期望)

UVA.12230.Crossing Rivers(期望)

UVA12230 过河 Crossing Rivers