Problem 1036 四塔问题

Posted qq77530202

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Problem 1036 四塔问题相关的知识,希望对你有一定的参考价值。

Accept: 590    Submit: 1506
Time Limit: 1000 mSec    Memory Limit : 32768 KB

技术分享 Problem Description

“汉诺塔”,是一个众所周知的古老游戏。现在我们把问题稍微改变一下:如果一共有4根柱子,而不是3根,那么至少需要移动盘子多少次,才能把所有的盘子从第1根柱子移动到第4根柱子上呢?

为了编程方便,您只需要输出这个结果mod 10000的值。

技术分享 Input

该题含有多组测试数据,每组一个正整数n。(0<n<=50000)

技术分享 Output

一个正整数,表示把n个盘子从第1根柱子移动到第4根柱子需要的最少移动次数mod 10000的值。

技术分享 Sample Input

15

技术分享 Sample Output

129
 
 
做法:找规律
#include<iostream>  
using namespace std;  
int main()  
{  
    int n;  
    while(cin>>n && n!=0)
    {  
        int f[50001]={0};  //不能用int f[n+1];
        int p = 1;  
        int q = p;  
        int k = 1;  
        for(int i = 1; i <= n; i++)
        {  
            f[i] = (f[i-1] + k) % 10000;  
            q--;  
            if(q==0)
           {  
               p++;  
               q = p;  
               k *= 2;  
               k %= 10000;
            }  
         }  
        cout<<f[n]<<endl;  
    }  
    return 0;  
}  

 


以上是关于Problem 1036 四塔问题的主要内容,如果未能解决你的问题,请参考以下文章

poj1958-汉诺四塔问题(三种方法)

PAT 1036 跟奥巴马一起编程

bzoj1036 [ZJOI2008]树的统计Count——LCT

bzoj 1036: [ZJOI2008]树的统计Count (树链剖分)

hihoCoder1036Trie图

P1036 选数