九度OJ刷题——1002:Grading

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了九度OJ刷题——1002:Grading相关的知识,希望对你有一定的参考价值。

题目描述:

    Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
    For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
    ? A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem‘s grade will be the average of G1 and G2.
    ? If the difference exceeds T, the 3rd expert will give G3.
    ? If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem‘s grade will be the average of G3 and the closest grade.
    ? If G3 is within the tolerance with both G1 and G2, then this problem‘s grade will be the maximum of the three grades.
    ? If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

    Each input file may contain more than one test case.
    Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

    For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0


这题逻辑很简单,但是有两个要注意的地方,一个是abs()函数是要包含<cmath>头文件,我本机编译环境是VS2012,没包含这个头文件没出错,但是OJ判Compile Error;另一个问题是小数点后显示固定位数的问题,用cout << setiosflags(ios::fixed) << setprecision(n)...实现,要包含头文件<iomanip>。
源代码:
#include <iostream>
#include <iomanip>
#include <cmath>
using namespace std;

int main(){
    double P, T, G1, G2, G3, GJ;
    double result;
    while(cin >> P >> T >> G1 >> G2 >> G3 >> GJ){
        int diff = abs(G1 - G2);
        if(diff <= T)
            result = (G1 + G2) / 2;
        else{
            int diff1 = abs(G3 - G1), diff2 = abs(G3 - G2);
            if(diff1 <= T && diff2 > T)
                result = (G1 + G3) / 2;
            else if(diff2 <= T && diff1 > T)
                result = (G2 + G3) / 2;
            else if(diff1 <= T && diff2 <= T)
                result = G1 >= G2 ? (G1 >= G3 ? G1 : G3) : (G2 >= G3 ? G2 : G3);
            else
                result = GJ;
        }
        cout << setiosflags(ios::fixed) << setprecision(1) << result << endl;
    }

    return 0;
}

 

以上是关于九度OJ刷题——1002:Grading的主要内容,如果未能解决你的问题,请参考以下文章

九度OJ刷题——1009:二叉搜索树

九度OJ刷题——1008:最短路径问题

九度OJ-题目1009:二叉搜索树

九度oj 题目1397:查找数段

刷题的网站

题目1002:Grading