28:单词倒排

Posted 自为

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了28:单词倒排相关的知识,希望对你有一定的参考价值。

28:单词倒排

总时间限制: 
1000ms
 
内存限制: 
65536kB
描述

编写程序,读入一行英文(只包含字母和空格,单词间以单个空格分隔),将所有单词的顺序倒排并输出,依然以单个空格分隔。

输入
输入为一个字符串(字符串长度至多为100)。
输出
输出为按要求排序后的字符串。
样例输入
I am a student
样例输出
student a am I
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char a[10001];
char ans[1001][1001];
int now1,now2;
int main()
{
    gets(a);
    int l=strlen(a);
    for(int i=0;i<l;i++)
    {
        if(a[i]!= )
        {
            ans[now1][now2]=a[i];
            now2++;
        }
        else 
        {
            now1++;
            now2=0;
        }
    }
    for(int i=now1;i>=0;i--)
    {
        printf("%s",ans[i]);
        cout<<" ";
    }
    return 0;
}

 

以上是关于28:单词倒排的主要内容,如果未能解决你的问题,请参考以下文章

单词倒排

单词倒排

OJ_单词倒排

倒排索引

35:字符串单词倒排 ReverseWords

搜索引擎基础概念—— 倒排列表