[建树(非二叉树)] 1106. Lowest Price in Supply Chain (25)

Posted 熊猫

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[建树(非二叉树)] 1106. Lowest Price in Supply Chain (25)相关的知识,希望对你有一定的参考价值。

1106. Lowest Price in Supply Chain (25)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID‘s are numbered from 0 to N-1, and the root supplier‘s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID‘s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
Sample Output:
1.8362 2

 

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int INF=1e9;
const int maxn=100010;

struct Node
{
    int data;
    vector<int> child;
}node[maxn];
int min_deep=INF;
int num[maxn]={0};

void dfs(int s,int & deep)
{
    if(node[s].child.size()==0)
    {
        num[deep]+=1;
        if(deep<min_deep)
        {
            min_deep=deep;
        }
        return ;
    }
    for(int i=0;i<node[s].child.size();i++)
    {
        int v=node[s].child[i];
        deep++;
        dfs(v,deep);
        deep--;
    }
}

int main()
{
    int n;
    double p,r;
    cin>>n>>p>>r;
    for(int i=0;i<n;i++)
    {
        int k;
        cin>>k;
        int id;
        for(int j=0;j<k;j++)
        {
            cin>>id;
            node[i].child.push_back(id);
        }
    }
    int deep=0;
    dfs(0,deep);
    deep=min_deep;
    double sum=p;
    while(min_deep>0)
    {
        min_deep-=1;
        sum*=1.0+r/100;
    }
    //printf("debug:%d",min_deep);
    printf("%.4lf %d\n",sum,num[deep]);
}

 

以上是关于[建树(非二叉树)] 1106. Lowest Price in Supply Chain (25)的主要内容,如果未能解决你的问题,请参考以下文章

在没有递归的情况下遍历非二叉树的算法是什么(使用堆栈)[重复]

非二叉树遍历方法

如何以增量方式构建非二叉树(具有依赖关系)

非二叉树递归

非二叉树的中序树遍历

如何在非二叉树中找到最长路径并将其返回到向量中?