反片语(map)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了反片语(map)相关的知识,希望对你有一定的参考价值。

输入一些单词,找出所有满足如下条件的单词:

该单词不能通过字母重排,得到输入文本中的另外一个单词。

在判断是否满足条件时,不区分大小写,但输出保留输入中的大小写,按字典序进行排列(所有大写字母在小写字母的前面)

样例输入:

ladder came tape soon leader acme RIDE lone Dreis peat

ScALE orb eye Rides dealer NotE derail LaCeS drIed

noel dire Disk mace Rob dires

#

样例输出:

Disk
NotE
derail
drIed
eye
ladder
soon

分析:把每个单词“标准化”,即全部转化为小写字母后再进行排序,然后再放到map中进行统计

#include<iostream>
#include<string>
#include<cctype>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
map<string,int>cnt;
vector<string>words;

string repr(const string & s)             //将单词s进行标准化
{
    string ans=s;
    for(int i=0;i<ans.length();i++)
        ans[i]=tolower(ans[i]);
    sort(ans.begin(),ans.end());           //sort可以对任意对象进行排序
    return ans;
}
int main() 
{
    int n=0;
    string s;
    while(cin>>s){
        if(s[0]==#)break;
        words.push_back(s);              //在vector words尾部加入一个数据s
        string r=repr(s);             //r为标准化后的字符串
        if(!cnt.count(r))cnt[r]=0;        //count(n) 返回容器中n出现的次数   若不为0,则使该r对应的int 为0
        cnt[r]++;
    }
    vector<string>ans;
    for(int i=0;i<words.size();i++)
        if(cnt[repr(words[i])]==1)ans.push_back(words[i]);        
    sort(ans.begin(),ans.end());
    for(int i=0;i<ans.size();i++)cout<<ans[i]<<endl;
    //system("pause");
    return 0;
}

 

以上是关于反片语(map)的主要内容,如果未能解决你的问题,请参考以下文章

Ananagrams(反片语)map的应用P114

C++ 映射:map 例5-4 反片语(UVa 156)

反片语 (Ananagrams,UVa 156)

反片语(UVa156)

uva 156 - Ananagrams (反片语)

算法入门经典 第五章