HDU1358 KMP(最短循环节)

Posted LuZhiyuan

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU1358 KMP(最短循环节)相关的知识,希望对你有一定的参考价值。

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7535    Accepted Submission(s): 3628


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

 

Sample Input
3
aaa
12
aabaabaabaab
0
 

 

Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
 

题意:

求字符串s每个前缀的最短循环节。求一个最大整数k,使得s的前i个字符组成的前缀是某个字符串重复k次得到的,输出i和k。

代码:

//白书213页例题。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char P[1000006];
int n,f[1000006];
int main()
{
    int cas=0;
    while(scanf("%d",&n)&&n){
        scanf("%s",P);
        f[0]=f[1]=0;
        for(int i=1;i<n;i++){
            int j=f[i];
            while(j&&P[i]!=P[j]) j=f[j];
            f[i+1]=(P[i]==P[j]?j+1:0);
        }
        printf("Test case #%d\n",++cas);
        for(int i=2;i<=n;i++)
            if(f[i]!=0&&i%(i-f[i])==0) printf("%d %d\n",i,i/(i-f[i]));
        printf("\n");
    }
    return 0;
}

 

以上是关于HDU1358 KMP(最短循环节)的主要内容,如果未能解决你的问题,请参考以下文章

HDU-1358 Period 字符串问题 KMP算法 求最小循环节

HDU 1358 Period

E - Period HDU-1358

hdu-1358 Period

Period HDU 1358 KMP next数组性质的应用

[KMP]HDU1358 Period