Maximum Clique

Posted 勿忘初心0924

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Maximum Clique相关的知识,希望对你有一定的参考价值。

Maximum Clique

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 92 Accepted Submission(s): 60
 
Problem Description
Given a graph G(V, E), a clique is a sub-graph g(v, e), so that for all vertex pairs v1, v2 in v, there exists an edge (v1, v2) in e. Maximum clique is the clique that has maximum number of vertex.
 
Input
Input contains multiple tests. For each test:

The first line has one integer n, the number of vertex. (1 < n <= 50)

The following n lines has n 0 or 1 each, indicating whether an edge exists between i (line number) and j (column number).

A test with n = 0 signals the end of input. This test should not be processed.
 
Output

            One number for each test, the number of vertex in maximum clique.
 
Sample Input
5
0 1 1 0 1
1 0 1 1 1
1 1 0 1 1
0 1 1 0 1
1 1 1 1 0
0
 
Sample Output
4
 
Author
CHENG, Long
 
Source
ZOJ Monthly, February 2003
 
Recommend
mcqsmall
 
/*
题意:就是给你一个图,然后输出最大团嘛
*/
#include<bits/stdc++.h>
using namespace std;

/***********************************最大团模板************************************/
struct MAX_CLIQUE {
    static const int N=60;

    bool G[N][N];
    int n, Max[N], Alt[N][N], ans;

    bool DFS(int cur, int tot) {
        if(cur==0) {
            if(tot>ans) {
                ans=tot;
                return 1;
            }
            return 0;
        }
        for(int i=0; i<cur; i++) {
            if(cur-i+tot<=ans) return 0;
            int u=Alt[tot][i];
            if(Max[u]+tot<=ans) return 0;
            int nxt=0;
            for(int j=i+1; j<cur; j++)
                if(G[u][Alt[tot][j]]) Alt[tot+1][nxt++]=Alt[tot][j];
            if(DFS(nxt, tot+1)) return 1;
        }
        return 0;
    }

    int MaxClique() {
        ans=0, memset(Max, 0, sizeof Max);
        for(int i=n-1; i>=0; i--) {
            int cur=0;
            for(int j=i+1; j<n; j++) if(G[i][j]) Alt[1][cur++]=j;
            DFS(cur, 1);
            Max[i]=ans;
        }
        return ans;
    }
};

MAX_CLIQUE fuck;
/***********************************最大团模板************************************/
int n;
int main(){
    // freopen("in.txt","r",stdin);
    while(scanf("%d",&fuck.n)!=EOF&&fuck.n){
        for(int i=0;i<fuck.n;i++){
            for(int j=0;j<fuck.n;j++){
                scanf("%d",&fuck.G[i][j]);
            }
        }
        printf("%d\n",fuck.MaxClique());
    }
    return 0;
}

 

以上是关于Maximum Clique的主要内容,如果未能解决你的问题,请参考以下文章

leetcode_1292. Maximum Side Length of a Square with Sum Less than or Equal to Threshold_[二维前缀和](代码片段

The Largest Clique UVA - 11324

UVA11324 The Largest Clique —— 强连通分量 + 缩点 + DP

UVa 11324 The Largest Clique (强连通分量+DP)

证明CLIQUE(团问题)是NP完全

PAT 1142 Maximal Clique