ALGO-79删除数组零元素

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了ALGO-79删除数组零元素相关的知识,希望对你有一定的参考价值。

  算法训练 删除数组零元素  
时间限制:1.0s   内存限制:512.0MB
 
   
从键盘读入n个整数放入数组中,编写函数CompactIntegers,删除数组中所有值为0的元素,其后元素向数组首端移动。注意,CompactIntegers函数需要接受数组及其元素个数作为参数,函数返回值应为删除操作执行后数组的新元素个数。输出删除后数组中元素的个数并依次输出数组元素。
样例输入: (输入格式说明:5为输入数据的个数,3 4 0 0 2 是以空格隔开的5个整数)
5
3 4 0 0 2
样例输出:(输出格式说明:3为非零数据的个数,3 4 2 是以空格隔开的3个非零整数)
3
3 4 2
样例输入: 
7
0 0 7 0 0 9 0
样例输出:
2
7 9
样例输入: 
3
0 0 0
样例输出:
0
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while (sc.hasNext()) {
            int[] arr = new int[10010];
            int n = sc.nextInt();
            for (int i = 0; i < n; i++) {
                arr[i] = sc.nextInt();
            }
            int len = CompactIntegers(arr, n);
            System.out.println(len);
            for (int i = 0; i < len; i++) {
                if (i == len - 1)
                    System.out.println(arr[i]);
                else
                    System.out.print(arr[i] + " ");
            }
        }
        sc.close();

    }

    private static int CompactIntegers(int[] arr, int n) {
        int pos = 0;
        for (int i = 0; i < n; i++) {
            if (arr[i] == 0) {
                continue;
            } else {
                arr[pos] = arr[i];
                pos++;
            }
        }
        return pos;
    }
}

 

以上是关于ALGO-79删除数组零元素的主要内容,如果未能解决你的问题,请参考以下文章

如何从 NumPy 数组中删除所有零元素?

算法训练——删除数组零元素

matlab中怎么求数组中非零元素的个数

golang删除数组某个元素

MATLAB中查找数组中的非零元素用啥函数

《C#零基础入门之百识百例》(八十三)ArrayList数组列表详解 -- 代码示例