AC日记——爱改名的小融3 codevs 3156

Posted Only U - IU

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了AC日记——爱改名的小融3 codevs 3156相关的知识,希望对你有一定的参考价值。

3156 爱改名的小融 3

 

 时间限制: 1 s
 空间限制: 128000 KB
 题目等级 : 黄金 Gold
 
 
 
题目描述 Description

Wikioi上有个人叫小融,他喜欢改名。
现在他的要求变了,只要是英文字母就是他的名字。
先给你N个名字,请你输出正确名字的个数及编号。
本题还加强了测试数据

输入描述 Input Description

N
N行名字(全部为字符)

输出描述 Output Description

第一行:个数
第二行:编号

样例输入 Sample Input

3
&6*14315
Rinkement
micsloox

样例输出 Sample Output

2
2 3 

数据范围及提示 Data Size & Hint

对于40%的数据 N≤10 名字长度≤100
对于100%的数据 N≤50 名字长度≤100000

 
思路:
  模拟;
 
 
来,上代码:
#include <cstdio>
#include <string>
#include <iostream>
#include <algorithm>

using namespace std;

int n,ans,flag[1010];

string ch;

int main()
{
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        cin>>ch;
        bool if_=true;
        for(int j=0;j<ch.length();j++)
        {
            if((ch[j]>=a&&ch[j]<=z)||(ch[j]>=A&&ch[j]<=Z));
            else
            {
                //printf("NO\n");
                if_=false;
                break;
            }
        }
        if(if_)
        {
            flag[++ans]=i;
        }
    }
    printf("%d\n",ans);
    for(int i=1;i<=ans;i++) printf("%d ",flag[i]);
    return 0;
}

 

以上是关于AC日记——爱改名的小融3 codevs 3156的主要内容,如果未能解决你的问题,请参考以下文章

AC日记——爱改名的小融2 codevs 3149

codevs 3165 爱改名的小融2

爱改名的小融 2(codevs 3149)

爱改名的小融

爱改名的小融1

CODEVS 必做题:31492821153133691230