堆积木----vector防止内存超限

Posted 行尸走肉

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了堆积木----vector防止内存超限相关的知识,希望对你有一定的参考价值。

蒜头君有 nn 块积木,编号分别为 11 到 nn。一开始,蒜头把第 ii 块积木放在位置 ii。蒜头君进行 mm 次操作,每次操作,蒜头把位置 bb 上的积木整体移动到位置 aa 上面。比如 11 位置的积木是 11,22 位置的积木是 22,那么把位置 22 的积木移动到位置 11 后,位置 11 上的积木从下到上依次为 1,21,2。

输入格式

第一行输入 22 个整数 n,m(1 \le n \le 10000, 0 \le m \le 10000)n,m(1n10000,0m10000)。

接下来 mm 行,每行输入 22 个整数 a, b(1 \le a, b \le n)a,b(1a,bn),如果aa,bb 相等则本次不需要移动。

输出格式

输出 nn 行,第 ii 行输出位置 ii 从下到上的积木编号,如果该行没有积木输出一行空行。

样例输入1

2 2
1 2
1 2

样例输出1

1 2

样例输入2

4 4
3 1
4 3
2 4
2 2

样例输出2

2 4 3 1



这道题用vector计算很简单。但是会存在内存超限的问题。
#include<bits/stdc++.h>
using namespace std;
vector<int> a[10005];
void mov(int to,int from)
{
    for(int i=0;i<a[from].size();i++)
    {
        a[to].push_back(a[from][i]);
    }
    /*vector<int> x;
    a[from].swap(x);*/
    a[from].clear();  
}
int main()
{


    int n,m;
    cin>>n>>m;

    for(int i=1;i<=n;i++)
        a[i].push_back(i);
    for(int i=0;i<m;i++)
    {
        int from,to;
        cin>>to>>from;
        if(from!=to)
            mov(to,from);
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=0;j<a[i].size();j++)
        {
            cout<<a[i][j];
            if(j!=a[i].size()-1) cout<<" ";
        }
        cout<<endl;
    }
    return 0;
}

使用注释中的的清空方法,可以释放掉内存。从而避免内存超限。

以上是关于堆积木----vector防止内存超限的主要内容,如果未能解决你的问题,请参考以下文章

51nod 3174树状数组堆积木

2060 堆积木

BZOJ 1109: [POI2007]堆积木Klo

[POI2007]堆积木Klo

bzoj1109[POI2007]堆积木Klo*

BZOJ1109[POI2007]堆积木Klo 二维偏序