ACM-The Coco-Cola Store

Posted 92#

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了ACM-The Coco-Cola Store相关的知识,希望对你有一定的参考价值。

题目:

Once upon a time, there is a special coco-cola store. If you return three empty bottles to the shop, you‘ll get a full bottle of coco-cola to drink. If you have n empty bottles right in your hand, how many full bottles of coco-cola can you drink?

输入

There will be at most 10 test cases, each containing a single line with an integer n (1<=n<=100). The input terminates with n = 0, which should not be processed

输出

For each test case, print the number of full bottles of coco-cola that you can drink.

样例输入

3
10
81
0

样例输出

1
5
40

题意:3个空瓶子换一瓶可乐,注意2个空瓶子的时候,借一个空瓶子的情况。

AC code

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
  int n;
  while(scanf("%d", &n),n){
      int sum = 0;
      while(n>=2){
          if(n ==2){
            n++;
          }else{
            sum += n/3;
            n = n/3+n%3;
          }
      }
      cout<<sum<<endl;
   }
 return 0;
}

 

 

 

以上是关于ACM-The Coco-Cola Store的主要内容,如果未能解决你的问题,请参考以下文章

vuex/store使用

如何测试 vuex 插件 store.subscribe

上传到 App Store 时出错“缺少代码签名权利”

Mac App Store 权利 - 代码对象根本没有签名

如何在引入 Xcode 源代码控制时避免 Ds_Store 和 pod?

如何在HBuilderX的自定代码块中输出$符号 - 带$符号输出this.$store.getter