Doing Homework_状态压缩

Posted 阿宝的锅锅

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Doing Homework_状态压缩相关的知识,希望对你有一定的参考价值。

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject‘s name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject‘s homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

 

Sample Input
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

 

Sample Output
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.
 

 【题意】给出n个作业名称、截止日期、完成需要花费的时间,求最少需要扣多少

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int inf=0x7777777;
const int N=(1<<15)+10;

int n;
int dp[N];//记录状态i扣得最少分数
int t[N];//相应过去了多少天
int pre[N],dt[N],ti[N];
char s[20][110];

void print(int x)
{
    if(!x) return ;
    print(x-(1<<pre[x]));
    printf("%s\n",s[pre[x]]);
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s%d%d",&s[i],&dt[i],&ti[i]);
        }
        
        for(int i=1;i<(1<<n);i++)//枚举1到1<<n的状态
        {
            dp[i]=inf;//初始化
            for(int j=n-1;j>=0;j--)
            {
                int tmp=1<<j;
                if(!(i&tmp)) continue;//状态i不存在作业j完成则不能通过
                //完成作业j到达状态i
                int front=i-tmp;//i-tmp表示没有完成作业j的之前那个状态
                int sc=t[front]+ti[j]-dt[j];
                if(sc<0) sc=0;//完成作业j,扣分0;
                if(dp[i]>dp[front]+sc)
                {
                    dp[i]=dp[front]+sc;
                    t[i]=t[front]+ti[j];//从front状态到i状态加上作业j的时间
                    pre[i]=j;//到达状态i的前提完成j作业
                }
            }
        }
        printf("%d\n",dp[(1<<n)-1]);
        print((1<<n)-1);
    }
    return 0;
}

 

以上是关于Doing Homework_状态压缩的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1074 Doing Homework(状态压缩DP)

状态压缩DP,附上例题(HDU - 1074 Doing Homework )

Doing Homework HDU - 1074 状态压缩

Doing Homework---hdu1074(状态压缩&&记忆化搜索)

状态压缩DP Doing Homework

HDU 1074 Doing Homework 状态压缩DP