-又见GCD -- ACM解决方法
Posted
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了-又见GCD -- ACM解决方法相关的知识,希望对你有一定的参考价值。
Input
第一行输入一个n,表示有n组测试数据,接下来的n行,每行输入两个正整数a,b。
Output
输出对应的c,每组测试数据占一行。
Sample Input
2 6 2 12 4
Sample Output
4 8
-----------------------------------------------------------------------------------------------------------
思路:
b是a,c的最大公约数,因此c可以被b整除,即c是b的倍数。
通过i*b的循环,在gcd(a,i*b)的值等于b时,即i*b就是所要的c
-----------------------------------------------------------------------------------------------
代码如下:
# include <stdio.h>
# include <math.h>
int gcd (int a,int b)
{
int t;
if(a<b)
{
t = a;
a = b;
b = t;
}
while(b)
{
t = a%b;
a = b;
b = t;
}
return a;
}
int main (void)
{
int n,a,b,i;
while(scanf("%d\n",&n)!=EOF)
{
while(n--)
{
i = 1;
scanf("%d%d\n",&a,&b);
while(i++)
{
if(gcd(a,i*b)==b)
{
printf("%d\n",i*b);
break;
}
}
}
}
}
网址:https://vjudge.net/contest/149571#problem/H
以上是关于-又见GCD -- ACM解决方法的主要内容,如果未能解决你的问题,请参考以下文章
Vue报错:Uncaught TypeError: Cannot assign to read only property 'exports' of object 的解决方法(代码片段
CentOS yum 命令出现 [Errno 14] curl#6 - "Couldn't resolve host ..." 的解决方法(代码片段