Windows Message Queue

Posted 勿忘初心0924

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Windows Message Queue相关的知识,希望对你有一定的参考价值。

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 85 Accepted Submission(s): 53
 
Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 
Input
There‘s only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there‘re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 
Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there‘s no message in the queue, output "EMPTY QUEUE!". There‘s no output for "PUT" command.
 
Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
 
Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!
 
Author
ZHOU, Ran
 
Source
Zhejiang University Local Contest 2006, Preliminary
 
Recommend
linle
 
/*
题意:简单的模拟两个操作:GET获取优先级最高的,PUT压进栈东西

初步思路:优先队列,搞一下,本来想偷一下懒。把以前写的代码贴上,结果死活不对。
*/
#include<bits/stdc++.h>
using namespace std;
struct node{
    string name;
    int val;
    int Rank;
    int time;
    node(){}
    node(string a,int b,int c,int d){
        name=a;
        val=b;
        Rank=c;
        time=d;
    }
    bool operator < (const node &other) const{
        if(Rank==other.Rank)
            return time>other.time;
        return Rank>other.Rank;
    }
};
priority_queue<node> Message;
string op;
string name;
int times=0;
int val,Rank;
void init(){
    times=0;
    while(!Message.empty()) Message.pop();
}
int main(){
    // freopen("in.txt","r",stdin);
    init();
    while(cin>>op){
        if(op=="GET"){
            if(Message.empty()) puts("EMPTY QUEUE!");
            else{
                cout<<Message.top().name<<" "<<Message.top().val<<endl;
                Message.pop();
            }
        }else{
            cin>>name>>val>>Rank;
            Message.push(node(name,val,Rank,times++));
        }
    }    
    return 0;
}

 

以上是关于Windows Message Queue的主要内容,如果未能解决你的问题,请参考以下文章

Windows Message Queue

Windows Message Queue

Windows Message Queue(优先队列)

HDU 1509 Windows Message Queue

hdu1509(Windows Message Queue) 优先队列

zoj 2724 Windows Message Queue(使用priority_queue容器模拟消息队列)