TOJ-1321 The Brick Stops Here

Posted DGSX

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了TOJ-1321 The Brick Stops Here相关的知识,希望对你有一定的参考价值。

You have been hired by several clients of a factory that manufactures brass bricks. Brass is an alloy of copper and zinc; each brick weighs 1000 grams, and the copper content of a brick can range from 1 to 999 grams. (Note that brass with less than 55% or more than 62% of copper is practically useless; however, this is irrelevant for this question) The factory manufactures, through various processes, different types of brick, each of which has a different copper concentration and price. It distributes a catalog of these types to its customers.

Your clients desire to buy a certain number (M) of bricks, which for, uh, religious reasons must be of different types. They will be melted together, and the resultant mixture must have a concentration of at least CMin and at most CMax grams of copper per kilogram. Their goal is to pick the M types of brick so that the mixture has the correct concentration and the price of the collection is minimized. You must figure out how to do this. M, CMin, and CMax will vary depending on the client.

Input

The first part of input consists of a line containing a number N (1 ≤ N ≤ 200), the number of brick types, and then N lines containing the copper concentration (between 1 and 999) and price (in cents) of each brick type. No brick costs more than 10 dollars.

The second part consists of a line containing a number C (1 ≤ C ≤ 100), the number of clients you are serving, followed by C lines containing M (1 ≤ M ≤ 20), CMin (1 ≤ CMin ≤ 999), and CMax (1 ≤ CMax ≤ 999) for each client.

All input numbers will be positive integers.

Output

Output consists of a line for each client containing the minimum possible price for which they can purchase bricks to meet their demands. If there is no way to match their specifications, output "impossible".

Sample Input

11
550 300
550 200
700 340
300 140
600 780
930 785
730 280
678 420
999 900
485 390
888 800
3
2 500 620
9 550 590
9 610 620

Sample Output

420
impossible
3635



Source: Waterloo Local Contest Jun. 19, 1999

dp过程:

dp[0][0] = 0;//dp[i][j]表示i块砖铜总量j最小价格 
        d = min(20,n);
        for(k=1;k<=n;k++){
            for(j=20000;j>=con[k];j--){
                for(i=1;i<=d;i++){
                    if(dp[i-1][j-con[k]]!=INF){
                        dp[i][j] = min(dp[i][j],dp[i-1][j-con[k]]+prc[k]);
                    }
                }
            }
        }

开始时先循环i后循环j,结果导致每个铜砖被重复使用。

全部代码:

#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <memory.h>
using namespace std;
const int INF=0x3f3f3f3f;
int con[202],prc[202],dp[22][20002];
int n,c,m,cmin,cmax;
int main(){
    int i,j,k,d;
    while(~scanf("%d",&n)){
        memset(dp,INF,sizeof(dp));
        for(i=1;i<=n;i++){
            scanf("%d%d",&con[i],&prc[i]);
        }
        dp[0][0] = 0;//dp[i][j]表示i块砖铜总量j最小价格 
        d = min(20,n);
        for(k=1;k<=n;k++){
            for(j=20000;j>=con[k];j--){
                for(i=1;i<=d;i++){
                    if(dp[i-1][j-con[k]]!=INF){
                        dp[i][j] = min(dp[i][j],dp[i-1][j-con[k]]+prc[k]);
                    }
                }
            }
        }
        /*for(i=0;i<=d;i++){
            for(j=0;j<=20000;j++){
                if(dp[i][j]==INF) continue;
                else printf("%d %d %d   ",i,j,dp[i][j]);
            }
            printf("\n");
        }*/
        scanf("%d",&c);
        while(c--){
            scanf("%d%d%d",&m,&cmin,&cmax);
            if(m>n)    printf("impossible\n");
            else {
                int ans = INF;
                int l = m*cmin;    int h = m*cmax;
                for(i=l;i<=h;i++){
                    if(dp[m][i]<ans){
                        ans = dp[m][i];
                    }
                }
                if(ans!=INF)    printf("%d\n",ans);
                else printf("impossible\n");
            }
        }
        
    }
    return 0; 
}

 

以上是关于TOJ-1321 The Brick Stops Here的主要内容,如果未能解决你的问题,请参考以下文章

Kattis-Another Brick in the Wall

Fatal error: The slave I/O thread stops because master and slave have equal MySQL server UUIDs; the

配置MySQL主从复制报错Last_IO_Error: Fatal error: The slave I/O thread stops because master and slave have eq

主从复制报错Fatal error:The slave I/O thread stops because master and slave have equal MySQL server UUIDs;

Within K stops 最短路径 Cheapest Flights Within K Stops

如何修复丢失的brick?