1011. World Cup Betting (20)

Posted 我是一个小木匠!

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1011. World Cup Betting (20)相关的知识,希望对你有一定的参考价值。

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner‘s odd would be the product of the three odds times 65%.

For example, 3 games‘ odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output

T T W 37.98
#include "iostream"
using namespace std;
int main() {
    float a[3][3];
    int t[3];
    char p[3] = { W,T,L };
    float sum = 1;
    for (int i = 0; i < 3; i++) {
        float MAX = 0;
        for (int j = 0; j < 3; j++) {
            cin >> a[i][j];
            if (a[i][j] > MAX) {
                MAX = a[i][j];
                t[i] = j;
            }
        }
        sum *= MAX;
    }
    for (int i = 0; i < 3; i++) {
        cout << p[t[i]] << " ";
    }
    printf("%.2f\n", (sum * 0.65 - 1) * 2);
    return 0;
}

 

以上是关于1011. World Cup Betting (20)的主要内容,如果未能解决你的问题,请参考以下文章

1011. World Cup Betting (20)

1011 World Cup Betting (20 分)

PTA-1011——World Cup Betting

PAT1011:World Cup Betting

pat 1011 World Cup Betting(20 分)

PAT A1011 World Cup Betting