bzoj 2056: gift? 高精度?

Posted lkhll--qaz

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了bzoj 2056: gift? 高精度?相关的知识,希望对你有一定的参考价值。

2056: gift? 高精度?

Time Limit: 10 Sec  Memory Limit: 1 MB

Description

 

Input

输入的第一行为一个整数t。 接下来t行,每行包含九个自然数。

Output

输出t行 每行一个整数,表示2^a+2^b+2^c+2^d+2^e+2^f+2^g+2^h+i。

Sample Input

1
21 30 0 0 0 0 0 0 2147483647

Sample Output

3223322629

HINT

 
【数据规模】
40% t<=1000
100% t<=100000 a,b,c,d,e,f,g,h<=60 i<=9223372036854775808

Source

#include<cstdio>
#define ull unsigned long long
ull s,tmp;
int t,a[10];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        s=0;
        for(int i=0;i<8;i++) scanf("%d",&a[i]);
        scanf("%llu",&tmp);
        for(int i=0;i<8;i++) s+=(1LL<<a[i]);
        if(s!=1LL<<63||tmp!=s) printf("%llu\n",s+tmp);
        else puts("18446744073709551616");
    }
}

 

以上是关于bzoj 2056: gift? 高精度?的主要内容,如果未能解决你的问题,请参考以下文章

bzoj5406: Gift

Codeforces 506EMr.Kitayuta’s Gift&&BZOJ 4214黄昏下的礼物 dp转有限状态自动机+矩阵乘法优化

hdu 2056

数学建模基于matlab动态水波仿真含Matlab源码 2056期

数学建模基于matlab动态水波仿真含Matlab源码 2056期

bzoj4806~bzoj4809 象棋四连发 DP-高精度-匈牙利算法-dfs