[深度优先搜索] POJ 3620 Avoid The Lakes

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[深度优先搜索] POJ 3620 Avoid The Lakes相关的知识,希望对你有一定的参考价值。

Avoid The Lakes
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8173   Accepted: 4270

Description

Farmer John‘s farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

Source

 
原题大意: 给张地图,然后看看最大连通的面积。
解题思路: 快到新生赛了,每天刷两道水题。DFS
 
#include<stdio.h>
int map[120][120],ans,n,m,squ,max;
const int dx[2][4]={{0,0,1,-1},{1,-1,0,0}};
void dfs(int x,int y)
  {
  	 int i,xx,yy;
  	 for(i=0;i<4;++i)
  	   {
  	   	 xx=x+dx[0][i];yy=y+dx[1][i];
  	   	 if(xx>0&&yy>0&&xx<=n&&yy<=m&&map[xx][yy])
  	   	   {
  	   	   	  map[xx][yy]=0;
  	   	   	  ++squ;
  	   	   	  dfs(xx,yy);
		   }
	   }
	 return ;
  }
int main()
  {
  	 int k,i,j;
  	 scanf("%d%d%d",&n,&m,&k);
  	 while(k--)
  	   {
  	   	  scanf("%d%d",&i,&j);
  	   	  map[i][j]=1;
	   }
	 for(i=1;i<=n;++i)
	   for(j=1;j<=m;++j)
	     if(map[i][j])
	       {
	       	 squ=1;
	       	 map[i][j]=0;
		     dfs(i,j);
		     max=max<squ?squ:max;
		   }
	 printf("%d\n",max);
  	 return 0;
  }

  

以上是关于[深度优先搜索] POJ 3620 Avoid The Lakes的主要内容,如果未能解决你的问题,请参考以下文章

Oil Deposits (poj 1241) 搜索 (深度优先搜素)

POJ2488 深度优先搜索+回溯

[深度优先搜索] POJ 1426 Find The Multiple

深度优先搜索(DFS)与广度优先搜索(BFS)

搜索算法:深度优先搜索(DFS)

深度优先搜索(dfs),城堡问题