HDU5795A Simple Nim SG定理

Posted 2855669158

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU5795A Simple Nim SG定理相关的知识,希望对你有一定的参考价值。

A Simple Nim

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 980    Accepted Submission(s): 573

Problem Description
Two players take turns picking candies from n heaps,the player who picks the last one will win the game.On each turn they can pick any number of candies which come from the same heap(picking no candy is not allowed).To make the game more interesting,players can separate one heap into three smaller heaps(no empty heaps)instead of the picking operation.Please find out which player will win the game if each of them never make mistakes.
 
Input
Intput contains multiple test cases. The first line is an integer $1\le T\le 100$, the number of test cases. Each case begins with an integer n, indicating the number of the heaps, the next line contains N integers $s[0],s[1], ....,s[n-1]$, representing heaps with $s[0],s[1], ...,s[n-1]$ objects respectively.$(1\le n\le 10^6,1\le s[i]\le 10^9)$
 
Output
For each test case,output a line whick contains either"First player wins."or"Second player wins".
 
Sample Input
2
2
4 4
3
1 2 4
 
Sample Output
Second player wins.
First player wins.
 
题意:n堆石子,两个人轮流拿,每次可以选择任意一堆取任意个(不能不拿)或者将一个堆分成3个小堆,问先手胜还是后手胜。
题解:SG定理的应用,可以看做是Nim博弈,打表找规律,我也不会证
  i=8*k+7时SG[i]=8*k+8,i=8*k+8时SG[i]=8*k+7其他情况SG[i]=i。
#include<bits/stdc++.h>
#define N 45000
#define mes(x) memset(x, 0, sizeof(x));
#define ll __int64
const long long mod = 1e9+7;
const int MAX = 0x7ffffff;
using namespace std;
int dir[200], SG[200];
int getSG(int n){
    if(n == 0) return 0;
    if(n%8 == 0) return n-1;
    if(n%8 == 7) return n+1;//注意这里是n%8==7,不是n%7==0....
    return n;
}
int main()
{
    int T,t, i,n, ans;
    scanf("%d", &T);
    while(T--){
        scanf("%d", &n);
        for(ans=i=0;i<n;i++){
            scanf("%d", &t);
            ans ^= getSG(t);
        }
        if(ans==0) printf("Second player wins.\n");
        else printf("First player wins.\n");
    }
    return 0;
}

 

以上是关于HDU5795A Simple Nim SG定理的主要内容,如果未能解决你的问题,请参考以下文章

HDU 5795 A Simple Nim 打表求SG函数的规律

[hdu-5795]A Simple Nim 博弈 尼姆博弈 SG函数打表找规律

hdu5795 A Simple Nim 求nim求法,打表找sg值规律 给定n堆石子,每堆有若干石子,两个人轮流操作,每次操作可以选择任意一堆取走任意个石子(不可以为空) 或者选择一堆,把它分成

hdu3404 Switch lights

SG函数

博弈论进阶之Anti-SG游戏与SJ定理