HDU1162-Eddy's picture(最小生成树)

Posted Pic

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU1162-Eddy's picture(最小生成树)相关的知识,希望对你有一定的参考价值。

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends ‘s view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.
Input contains multiple test cases. Process to the end of file.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41

Author

eddy

Recommend

JGShining

这是一个最小生成树的模板题目

下面的代码用了Kruskal算法

#include <cstdio>
#include <vector>
#include <algorithm>
#include <cmath>

using namespace std;

const int N = 105;

struct Edge
{
    int x, y;
    double w;
};

struct Point
{
    double x;
    double y;
};

int pre[N];
Point point[N];
Edge edges[N * N / 2];

int i_p, i_e, cnt;
double res;

int root(int x)
{
    if (x != pre[x])
    {
        pre[x] = root(pre[x]);
    }
    return pre[x];
}

bool merge(int x, int y)
{
    int fx = root(x);
    int fy = root(y);

    bool ret = false;

    if (fx != fy)
    {
        pre[fx] = pre[fy];
        ret = true;
        --cnt;
    }
    return ret;
}

void init(int n)
{
    cnt = n;
    res = 0;

    for (int i = 0; i <= n; ++i)
    {
        pre[i] = i;
    }
}

bool cmp(const Edge &a, const Edge &b)
{
    return a.w < b.w;
}

int main()
{
    int n;
    double dx, dy;

    while (scanf("%d", &n) != EOF)
    {
        init(n);

        i_e = i_p = 0;

        for (int i = 0; i < n; ++i)
        {
            scanf("%lf %lf", &dx, &dy);
            point[i_p].x = dx;
            point[i_p].y = dy;
            ++i_p;
        }

        for (int i = 0; i < n; ++i)
        {
            for (int j = i + 1; j < n; ++j)
            {
                edges[i_e].x = i;
                edges[i_e].y = j;
                double dd = (point[i].x - point[j].x) * (point[i].x - point[j].x);
                dd += (point[i].y - point[j].y) * (point[i].y - point[j].y);
                edges[i_e].w = sqrt(dd);
                ++i_e;
            }
        }

        sort(edges, edges + i_e, cmp);

        //the cnt == 1 indicates that the mixnum spanning tree is builded sucessfully.
        for (int i = 0; i < i_e && cnt != 1; ++i)
        {
            if (merge(edges[i].x, edges[i].y))res += edges[i].w;
        }

        printf("%.2lf\n", res);
    }
    return 0;
}

以上是关于HDU1162-Eddy's picture(最小生成树)的主要内容,如果未能解决你的问题,请参考以下文章

HDU1162-Eddy's picture(最小生成树)

HDU 1162 Eddy's picture (最小生成树 prim)

hdu-1162 Eddy's picture---浮点数的MST

HDU 1162 Eddy's picture (最小生成树)(java版)

hdu1162 Eddy's picture 基础最小生成树

hdu 1162 Eddy&#39;s picture (Kruskal算法,prim算法,最小生成树)