Super Jumping! Jumping! Jumping!

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Super Jumping! Jumping! Jumping!相关的知识,希望对你有一定的参考价值。

Super Jumping! Jumping! Jumping!

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

技术分享


The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 
Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 
Output
For each case, print the maximum according to rules, and one line one case.
 
Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0
 
Sample Output
4
10
3
 
Answer
这题目巨坑,求的是最大子序列和(不清楚怎么讲,看数据),而不是最长子序列和(或者说最长不下降子串),所以一开始用贪心去试,挂了。。
测试数据:10 154 5 41 545 485 44 4 545 54 5444,答案是6628(蓝色之和)。
 
技术分享
#include <cstdio>
#include <iostream>
#include <sstream>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#define PI acos(-1.0)
#define ms(a) memset(a,0,sizeof(a))
#define msp memset(mp,0,sizeof(mp))
#define msv memset(vis,0,sizeof(vis))
#define msd memset(dp,0,sizeof(dp))
using namespace std;
//#define LOCAL
int dp[1001];
int a[1001];
int main()
{
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
    //freopen("out.txt","w",stdout);
#endif // LOCAL
    ios::sync_with_stdio(false);
    int n;
    while(cin>>n&&n)
    {
        msd,ms(a);
        for(int i=1; i<=n; i++)
            cin>>a[i];
        for(int i=1; i<=n; i++)
        {
            int ans=-999999999;
            for(int j=0; j<i; j++)
            {
                if(a[i]>a[j])
                ans=max(ans,dp[j]);
            }
            dp[i]=ans+a[i];
        }
        int ans=-999999999;
        for(int i=0;i<=n;i++)
        ans=max(ans,dp[i]);
        printf("%d\n",ans);
    }
    return 0;
}
View Code

以上是关于Super Jumping! Jumping! Jumping!的主要内容,如果未能解决你的问题,请参考以下文章

[2016-03-27][HDU][1087][Super Jumping! Jumping! Jumping!]

Super Jupmping ! Jumping ! Jumping

HDU-1087.Super Jumping! Jumping! Jumping!

hdu 1087 Super Jumping! Jumping! Jumping! (dp最大递增字段和)

HDu1087 Super Jumping! Jumping! Jumping!

Super Jumping! Jumping! Jumping! HDU - 1087