POJ1276(多重背包)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ1276(多重背包)相关的知识,希望对你有一定的参考价值。

Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 30973   Accepted: 11161

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int cash,n;
int a[15],m[15];
int dp[100005];
int main()
{
    while(scanf("%d%d",&cash,&n)!=EOF)
    {
        memset(dp,-1,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&m[i],&a[i]);
        }
        dp[0]=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<=cash;j++)
                if(dp[j]>=0)
                    dp[j]=m[i];
                else if(j<a[i]||dp[j-a[i]]<0)
                    dp[j]=-1;
                else    
                    dp[j]=dp[j-a[i]]-1;
        
        for(int i=cash;i>=0;i--)
            if(dp[i]>=0)
            {
                printf("%d\n",i);
                break;
            }
    }
    
    return 0;
}

转化为多重背包

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int cash,n;
int w[10005];
int dp[100005];
int main()
{
    while(scanf("%d%d",&cash,&n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        int cnt=0;
        for(int i=0;i<n;i++)
        {
            int num,v;
            scanf("%d%d",&num,&v);
            int e=1;
            while(e<num)
            {
                w[cnt++]=e*v;
                num-=e;
                e<<=1;
            }        
            if(num>0)
                w[cnt++]=num*v;
        }
        
        for(int i=0;i<cnt;i++)
            for(int j=cash;j>=w[i];j--)
                dp[j]=max(dp[j],dp[j-w[i]]+w[i]);
        
        printf("%d\n",dp[cash]);
    }
    
    return 0;
}

 

以上是关于POJ1276(多重背包)的主要内容,如果未能解决你的问题,请参考以下文章

POJ_1276_多重背包

POJ - 1276 Cash Machine(多重背包)

poj 1276 Cash Machine(多重背包)

poj 1276(多重背包+最接近)

POJ-1276 Cash Machine 多重背包 二进制优化

POJ 1276 Cash Machine(多重背包的二进制优化)