HDU 5533Dancing Stars on Me 基础几何

Posted ( m Lweleth)

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 5533Dancing Stars on Me 基础几何相关的知识,希望对你有一定的参考价值。

Problem Description

The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.
Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following nlines, each contains 2 integers xi,yi, describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
Sample Input
3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0
Sample Output
NO
YES
NO

题意:问你是不是正多边形。

思路:瞎暴力XD。直接存所有点间连线的边长,偶数多边形长度一样的肯定有n/2个和n个,奇数多边形相同边长的一定是n啦。

/** @Date    : 2016-12-10-22.55
  * @Author  : Lweleth ([email protected])
  * @Link    : https://github.com/
  * @Version :
  */
//#include <stdio.h>
//#include <iostream>
//#include <string.h>
//#include <algorithm>
//#include <utility>
//#include <vector>
//#include <map>
//#include <set>
//#include <string>
//#include <stack>
//#include <queue>
#include<bits/stdc++.h>
#define LL long long
#define PII pair<int ,int>
#define MP(x, y) make_pair((x),(y))
#define fi first
#define se second
#define PB(x) push_back((x))
#define MMG(x) memset((x), -1,sizeof(x))
#define MMF(x) memset((x),0,sizeof(x))
#define MMI(x) memset((x), INF, sizeof(x))
using namespace std;

const int INF = 0x3f3f3f3f;
const int N = 1e5+20;
const double eps = 1e-8;

struct yuu
{
    double x; double y;
    bool operator == (const yuu &a) const
    {
        return (a.x == this->x) && (a.y == this->y);
    }
}s[110], t[N];

int cmp(yuu a, yuu b)
{
    if(a.x != b.x)
        return a.x > b.x;
    return a.y > b.y;
}
map<double , int>q;
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int n;
        scanf("%d", &n);
        q.clear();
        for(int i = 1; i <= n; i++)
            scanf("%lf%lf", &s[i].x, &s[i].y);

        int cnt = 0;
        for(int i = 1; i <= n; i++)
        {
            for(int j = i + 1; j <= n; j++)
            {
                double mx = fabs(s[i].x - s[j].x);
                double my = fabs(s[i].y - s[j].y);
                double len = mx * mx + my * my;
                q[len]++;
            }
        }
        int flag = 0;
        for(auto i = q.begin(); i != q.end(); i++)
        {
            if(n & 1 && i->second != n)
            {
                flag = 1;
                break;
            }
            else if(n % 2 == 0)
            {
                if(i->second != n / 2 && i->second != n)
                {
                    flag = 1;
                    break;
                }
            }
        }
        if(flag)
            printf("NO\n");
        else printf("YES\n");


    }
    return 0;
}

以上是关于HDU 5533Dancing Stars on Me 基础几何的主要内容,如果未能解决你的问题,请参考以下文章

HDU_5533_Dancing Stars on Me

HDU 5533 Dancing Stars on Me 计算几何瞎暴力

Dancing Stars on Me HDU - 5533

Dancing Stars on Me---hdu5533(判断是否为正多边形)

HDU5046 Airport dancing links 重复覆盖+二分

HDU 5046 Airport ( Dancing Links 反复覆盖 )