Stars_树状数组

Posted 阿宝的锅锅

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Stars_树状数组相关的知识,希望对你有一定的参考价值。

Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

技术分享

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

 

Sample Input
5 1 1 5 1 7 1 3 3 5 5
 

 

Sample Output
1 2 1 1 0

 

 

 

【题意】给出n个星星的位置(y坐标是升序),求各阶级星星的个数,(阶级是该星星左下角星星的个数)

【思路】树状数组直接套就可以求出当前星星的level,用一个数组存储各阶级的星星数就可以了

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int N=15000+10;
int n;
int sum[N*4];
int level[N*4];
int lowbit(int x)
{
    return x&(-x);
}
void update(int x,int v)
{
    while(x<=32000)
    {
        sum[x]+=v;
        x+=lowbit(x);
    }
}
int query(int x)
{
    int res=0;
    while(x)
    {
        res+=sum[x];
        x-=lowbit(x);
    }
    return res;
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(level,0,sizeof(level));
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=n;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            level[query(++x)]++;
            update(x,1);
        }
        for(int i=0;i<n;i++)
            printf("%d\n",level[i]);
    }
    return 0;
}

 







以上是关于Stars_树状数组的主要内容,如果未能解决你的问题,请参考以下文章

[POJ2352] Stars(树状数组)

HDU1541 Stars(树状数组)

树状数组入门 hdu1541 Stars

POJ 2352-Stars-树状数组

poj--2352 Stars(树状数组)

Stars(树状数组单点更新)