AC日记——字符串判等 openjudge 1.7 17

Posted Only U - IU

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了AC日记——字符串判等 openjudge 1.7 17相关的知识,希望对你有一定的参考价值。

17:字符串判等

总时间限制: 
1000ms
 
内存限制:
 
65536kB
描述

判断两个由大小写字母和空格组成的字符串在忽略大小写,且忽略空格后是否相等。

输入
两行,每行包含一个字符串。
输出
若两个字符串相等,输出YES,否则输出NO。
样例输入
a A bb BB ccc CCC
Aa BBbb CCCccc
样例输出
YES

思路:

  大模拟;

 

来,上代码:

#include<cstdio>
#include<string>
#include<cstring>

using namespace std;

int len_1,len_2,now_1=0,now_2=0;

char word_1[100],word_2[100];

inline char char_(char &char__)
{
    if(char__<=z&&char__>=a) char__-=32;
}

int main()
{
    gets(word_1);
    gets(word_2);
    len_1=strlen(word_1),len_2=strlen(word_2);
    for(int i=0;i<=len_1;i++) char_(word_1[i]);
    for(int i=0;i<=len_2;i++) char_(word_2[i]);
    while(now_1<100||now_2<100)
    {
        if(word_1[now_1]== )
        {
            now_1++;
            continue;
        }
        if(word_2[now_2]== )
        {
            now_2++;
            continue;
        }
        if(word_1[now_1]!=word_2[now_2])
        {
            printf("NO\n");
            return 0;
        }
        now_1++,now_2++;
    }
    printf("YES\n");
    return 0;
}

 

以上是关于AC日记——字符串判等 openjudge 1.7 17的主要内容,如果未能解决你的问题,请参考以下文章

AC日记——简单密码 openjudge 1.7 10

AC日记——字符替换 openjudge 1.7 08

AC日记——验证字串 openjudge 1.7 18

AC日记——回文子串 openjudge 1.7 34

AC日记——字符串的展开 openjudge 1.7 35

AC日记——行程长度编码 openjudge 1.7 32