[POJ2586]Y2K Accounting Bug

Posted xjr_01

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[POJ2586]Y2K Accounting Bug相关的知识,希望对你有一定的参考价值。

[POJ2586]Y2K Accounting Bug

试题描述

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

(题目好难懂,可以去 http://blog.sina.com.cn/s/blog_768e348b0100xc53.html 看翻译。。。)

输入

Input is a sequence of lines, each containing two positive integers s and d.

输出

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

输入示例

59 237
375 743
200000 849694
2500000 8000000

输出示例

116
28
300612
Deficit

数据规模及约定

见“试题描述

题解

直接暴力咯。。。

不过也可以 dp 或是贪心。。。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <stack>
#include <vector>
#include <queue>
#include <cstring>
#include <string>
#include <map>
#include <set>
using namespace std;

int read() {
    int x = 0, f = 1; char c = getchar();
    while(!isdigit(c)){ if(c == ‘-‘) f = -1; c = getchar(); }
    while(isdigit(c)){ x = x * 10 + c - ‘0‘; c = getchar(); }
    return x * f;
}

#define maxn 15
int A[maxn];

int main() {
	int s, d;
	while(scanf("%d%d", &s, &d) == 2) {
		int all = (1 << 12) - 1, ans = -1;
		for(int i = 0; i <= all; i++) {
			int sum = 0;
			for(int j = 0; j < 12; j++) {
				if(i >> j & 1) A[j] = s;
				else A[j] = -d;
				sum += A[j];
			}
			int S = 0;
			for(int j = 0; j < 5; j++) S += A[j];
			if(S >= 0) continue;
			bool ok = 1;
			for(int j = 1; j < 8; j++) {
				S = S - A[j-1] + A[j+4];
				if(S >= 0) { ok = 0; break; }
			}
			if(!ok) continue;
			ans = max(ans, sum);
		}
		if(ans >= 0) printf("%d\n", ans);
		else puts("Deficit");
	}
	
	return 0;
}

 

以上是关于[POJ2586]Y2K Accounting Bug的主要内容,如果未能解决你的问题,请参考以下文章

POJ 2586 Y2K Accounting Bug

poj 2586 Y2K Accounting Bug

POJ2586 -- Y2K Accounting Bug

POJ - 2586 Y2K Accounting Bug (找规律)

POJ 2586 Y2K Accounting Bug(枚举大水题)

poj 2586 Y2K Accounting Bug贪心刷题计划