See you~_树状数组

Posted 阿宝的锅锅

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了See you~_树状数组相关的知识,希望对你有一定的参考价值。

Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year. 
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles. 
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position. 
 

 

Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed. 
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries. 
There are 4 kind of queries, sum, add, delete and move. 
For example: 
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points. 
A x1 y1 n1 means I put n1 books on the position (x1,y1) 
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them. 
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them. 
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100. 
 

 

Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries. 
For each "S" query, just print out the total number of books in that area. 
 

 

Sample Input
2 3 S 1 1 1 1 A 1 1 2 S 1 1 1 1 3 S 1 1 1 1 A 1 1 2 S 1 1 1 2
 

 

Sample Output
Case 1: 1 3 Case 2: 1 4

 

 

【题意】1000*1000个格子,每个格子里放一本书,可以增加,减少,移动,求给出矩阵内的书的数量

【思路】二维树状数组,要注意的是,从坐标0,0开始,为了避免while(0),都加一进行更新,减少的时候要比较当前的数量是否大于要减少的数量

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int N=1000+5;
int n;
int sum[N][N];
int lowbit(int x)
{
    return x&(-x);
}

void update(int x,int y,int a)
{
    while(x<N)
    {
        int t=y;
        while(t<N)
        {
            sum[x][t]+=a;
            t+=lowbit(t);
        }
        x+=lowbit(x);
    }
}
int get_sum(int x,int y)
{
    int res=0;
    while(x)
    {
        int t=y;
        while(t)
        {
            res+=sum[x][t];
            t-=lowbit(t);
        }
        x-=lowbit(x);
    }
    return res;
}
int get_a(int x,int y)
{
    return get_sum(x,y)-get_sum(x-1,y)-get_sum(x,y-1)+get_sum(x-1,y-1);
}

int main()
{
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        printf("Case %d:\n",cas++);
        scanf("%d",&n);
        memset(sum,0,sizeof(sum));
        for(int i=1; i<=N; i++)
        {
            for(int j=1; j<=N; j++)
            {
                update(i,j,1);
            }
        }

        for(int i=1; i<=n; i++)
        {
            char s[10];
            int x,y,a,b,z;
      
            scanf("%s ",s);
            if(s[0]==A||s[0]==D)
            {
                scanf("%d%d%d",&x,&y,&a);
                if(s[0]==D) a=-min(a,get_a(x+1,y+1));//判断现在的数量是否多于要减少的数量,如果不是,就全搬走就可。
                update(x+1,y+1,a);
            }
            else if(s[0]==M)
            {
               scanf("%d%d%d%d%d",&x,&y,&a,&b,&z);
               z=min(z,get_a(x+1,y+1));
               update(x+1,y+1,-z);
               update(a+1,b+1,z);
            }
            else
            {
                scanf("%d%d%d%d",&x,&y,&a,&b);
                if(a<x) swap(a,x);
                if(b<y) swap(b,y);
                int tmp=get_sum(a+1,b+1)-get_sum(a+1,y)-get_sum(x,b+1)+get_sum(x,y);
                printf("%d\n",tmp);
            }
        }
    }

    return 0;
}

 

以上是关于See you~_树状数组的主要内容,如果未能解决你的问题,请参考以下文章

TOJ 2725 See you~(二维树状数组单点更新区间查询)

二维树状数组See you~

hdu-1892 See you~---二维树状数组运用

See you~ HDU1892

ubuntu16.04 yum报错:There are no enabled repos. Run “yum repolist all“ to see the repos you have.(代码片段

I'm sorry to tell you that I have to work overtime.you see my job is _____