Is It A Tree?

Posted 勿忘初心0924

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Is It A Tree?相关的知识,希望对你有一定的参考价值。

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1145 Accepted Submission(s): 355
 
Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

技术分享技术分享技术分享


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
 
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 
Output

            For each test case display the line ``Case k is a tree.\\\\\\\" or the line ``Case k is not a tree.\\\\\\\", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
 
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
 
 
Source
North Central North America 1997
 
Recommend
Ignatius.L
 
/*
不能有环,每个点的入度小于2
*/
#include<bits/stdc++.h>
using namespace std;
int bin[100005];
int vis[100005];
int findx(int x)
{
    while(bin[x]!=x)
        x=bin[x];
    return x;
}
int build(int a,int b)
{
    int fx=findx(a);
    int fy=findx(b);
    if(fx!=fy)
    {
        bin[fx]=fy;
        return false;
    }
    else//有环
        return true;
}
int cur=0;
int f=0;
int len=0;
vector<int >v;
int a,b;
map<int ,int>m;
void inti()
{
    for(int i=0;i<100005;i++)
    {
        f=0;
        cur=0;
        len=0;
        bin[i]=i;
        vis[i]=false;
    }
    v.clear();
    m.clear();
}
int main()
{
    //freopen("C:\\Users\\acer\\Desktop\\in.txt","r",stdin);
    int c=1;
    while(scanf("%d%d",&a,&b)!=EOF)//输入的是每组的第一组数
    {
        if(a<0&&b<0)
            break;
        if(!a&&!b)
        {
            printf("Case %d is a tree.\n",c++);
            continue;
        }
        inti();
        if(!vis[a])
            v.push_back(a);
        if(!vis[b])
            v.push_back(b);
        vis[a]=true;
        vis[b]=true;
        if(build(a,b))
            f=1;
        while(scanf("%d%d",&a,&b)!=EOF)
        {
            if(!a&&!b)
                break;
            if(!vis[a])
                v.push_back(a);
            if(!vis[b])
                v.push_back(b);
            vis[a]=true;
            vis[b]=true;
            if(m[b]==0)
                m[b]++;
            else
                f=1;
            if(build(a,b))
                f=1;
        }
        if(!f)
        {
            int root=findx(v[0]);
            for(int i=1;i<v.size();i++)
            {
                if(findx(v[i])!=root)
                {
                    f=1;
                    break;
                }
            }
        }
        if(!f)
            printf("Case %d is a tree.\n",c++);
        else
            printf("Case %d is not a tree.\n",c++);

    }
    return 0;
}

 

以上是关于Is It A Tree?的主要内容,如果未能解决你的问题,请参考以下文章

1135. Is It A Red-Black Tree (30)

poj 1308 Is It A Tree?

A11231123 Is It a Complete AVL Tree (30分)

A11231123 Is It a Complete AVL Tree (30分)

1043 Is It a Binary Search Tree (25分)

Is It A Tree?