Balanced Lineup

Posted 蒟蒻sjy

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Balanced Lineup相关的知识,希望对你有一定的参考价值。

 
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 49061   Accepted: 22975
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John\'s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0


题目大意:给出一个数字序列,对于每次提问,输出区间(i,j)内的最大值数与最小值数的差。ST算法
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N  50010
#define ll long long
using namespace std;
int f[N][20],fi[N][20],a[N];
int n,m;
void RMQ()
{
    for (int i=1;i<=n;i++) f[i][0]=a[i],fi[i][0]=a[i];
    for (int i=1;i<=int(log(n)/log(2));i++)
      for (int j=1;j<=n+1-(1<<i);j++)
        {
            f[j][i]=max(f[j][i-1],f[j+(1<<i-1)][i-1]);//区间最大值 
            fi[j][i]=min(fi[j][i-1],fi[j+(1<<i-1)][i-1]);//区间最小值 
        }
        
}
int main()
{
    while (scanf("%d%d",&n,&m)!=EOF)
      {
         for (int i=1;i<=n;i++) scanf("%d",&a[i]);
         RMQ();
         for (int i=1,x,y;i<=m;i++)
            {
                 scanf("%d%d",&x,&y);
                 int k; 
                 k=(int)(log(y-x+1)/log(2));
                 int ans1=max(f[x][k],f[y-(1<<k)+1][k]),//两个区间存在重叠 
                     ans2=min(fi[x][k],fi[y-(1<<k)+1][k]);
                 printf("%d\\n",ans1-ans2);
            }
      }
   
    return 0;
}
ST

 

模板题。


 

 
 

以上是关于Balanced Lineup的主要内容,如果未能解决你的问题,请参考以下文章

Balanced Lineup -POJ3264

POJ3264 Balanced Lineup

POJ 3264 Balanced Lineup

Balanced Lineup——区间最大值区间最小值

poj 3264 Balanced Lineup

poj3264_Balanced Lineup