An easy problem

Posted 行尸走肉

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了An easy problem相关的知识,希望对你有一定的参考价值。

An easy problem
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc.. 

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem : 

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ? 

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve. 
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ? 

Input

The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10 10).

Output

For each case, output the number of ways in one line.

Sample Input

2
1
3

Sample Output

0
1

#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        long long n;
        scanf("%I64d",&n);
        n++;
        int ans=0;
        long long m=sqrt(n);
        for(long long i=2;i<=m;i++)
        {
            if(n%i==0) ans++;
        }
        printf("%d\\n",ans);
    }
}
View Code

n=i*j+i+j

==>n+1=(i+1)*(j+1)

 

 

以上是关于An easy problem的主要内容,如果未能解决你的问题,请参考以下文章

An easy problem

an easy problem(贪心)

D - An easy problem

An easy problem(位运算)

An easy problem

[openjudge] 1455:An Easy Problem 贪心