C - Big Number

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了C - Big Number相关的知识,希望对你有一定的参考价值。

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.        
                

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.        
                

Output

The output contains the number of digits in the factorial of the integers appearing in the input.        
                

Sample Input

2 10 20
                

Sample Output

7 19
 
 
求一个数阶乘的位数  n的位数为log10(n)+1    将大数利用log变为小数直接来计算位数
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        int a;
        double b=0;
        cin>>a;
        for(int i=2;i<=a;i++){
            b+=log10((double)i);
        }
        cout<<(int)b+1<<endl;
    }
    //system("pause");
    return 0;
}

 

 
 

以上是关于C - Big Number的主要内容,如果未能解决你的问题,请参考以下文章

C 中的共享内存代码片段

1018 Big Number 简单数论

Big Number

HDU 1018 Big Number

HDU 1018 Big Number 数学题

Big Number