Matrix Swapping II(求矩阵最大面积,dp)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Matrix Swapping II(求矩阵最大面积,dp)相关的知识,希望对你有一定的参考价值。

Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1543    Accepted Submission(s): 1036

Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness. 
We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
 

 

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
 

 

Output
Output one line for each test case, indicating the maximum possible goodness.
 

 

Sample Input
3 4 1011 1001 0001 3 4 1010 1001 0001
 

 

Sample Output
4 2 Note: Huge Input, scanf() is recommended.
 
题解:

也是求最大矩阵的,只不过可以相互交换任意两列。

访问每一行时,求出每个点的高度,然后排序,以该点为高时的宽度就很容易看出来,面积取最大的就可以了。

ans=max(ans,(k-j+1)*s[j]);由于可以交换列,这里随着往右走,宽度逐渐减小,找最大值;

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
const int INF=0x3f3f3f3f;
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define PI(x) printf("%d",x)
#define SD(x) scanf("%lf",&x)
#define P_ printf(" ")
typedef long long LL;
const int MAXN=1010;
char mp[MAXN][MAXN];
int dp[MAXN][MAXN];
int s[MAXN];
int main(){
    int N,M;
    while(~scanf("%d%d",&N,&M)){
        mem(dp,0);
        int ans=0;
        for(int i=1;i<=N;i++){
            scanf("%s",mp[i]);
            for(int j=M;j>=1;j--){
                mp[i][j]=mp[i][j-1];
            }
        }
        for(int i=1;i<=N;i++){
            int k=0;
            for(int j=1;j<=M;j++){
                if(mp[i][j]==1){
                    dp[i][j]=dp[i-1][j]+1;
                    s[++k]=dp[i][j];
                }
            }
            sort(s+1,s+k+1);
            for(int j=1;j<=k;j++){
                ans=max(ans,(k-j+1)*s[j]);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

 

以上是关于Matrix Swapping II(求矩阵最大面积,dp)的主要内容,如果未能解决你的问题,请参考以下文章

leetcode 240. 搜索二维矩阵 II(Search a 2D Matrix II)

LeetCode 240. 搜索二维矩阵 II Search a 2D Matrix II (Medium)

Leetcode之二分法专题-240. 搜索二维矩阵 II(Search a 2D Matrix II)

[LeetCode] 240. Search a 2D Matrix II 搜索一个二维矩阵 II

240 Search a 2D Matrix II 搜索二维矩阵 II

LeetCode-面试算法经典-Java实现059-Spiral Matrix II(螺旋矩阵II)