(POJ 3694) Network 求桥个数

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了(POJ 3694) Network 求桥个数相关的知识,希望对你有一定的参考价值。

题目链接:http://poj.org/problem?id=3694

Description A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can
t be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges. You are to help the administrator by reporting the number of bridges in the network after each new link is added. Input The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000). Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network. The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one. The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B. The last test case is followed by a line containing two zeros. Output For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case. Sample Input 3 2 1 2 2 3 2 1 2 1 3 4 4 1 2 2 1 2 3 1 4 2 1 2 3 4 0 0 Sample Output Case 1: 1 0 Case 2: 2 0

题目大意:有N个点,M条边,添加Q条边,问每填一条边,还有几条桥?

#include<stdio.h>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<queue>
#include<math.h>
#include <stack>
using namespace std;
#define ll long long
#define INF 0x3f3f3f3f
#define met(a,b) memset(a,b,sizeof(a))
#define mod 2147493647
#define N 100100
int low[N],dfn[N],vis[N];
int fa[N];
int n,t,ans;
int bin[N];
vector<vector<int> >Q;
void init()
{
    met(low,0);
    met(dfn,0);
    t=0;
    Q.clear();
    Q.resize(n+10);
    met(bin,0);
    met(fa,0);
}
void tarjin(int u,int f)
{
    low[u]=dfn[u]=++t;
    fa[u]=f;
    int l=Q[u].size();
    for(int i=0; i<l; i++)
    {
        int v=Q[u][i];
        if(!dfn[v])
        {
            tarjin(v,u);
            low[u]=min(low[u],low[v]);
            if(dfn[u]<low[v])///开始没被查找,可能是桥
            {
                bin[v]++;
                ans++;
            }
        }
        else if(f!=v)
        {
            low[u]=min(low[u],dfn[v]);
            if(dfn[u]<low[v])///被查找过,有两条路通这个点,不是桥
            {
                bin[v]--;
                ans--;
            }
        }
    }
}
void LCR(int a,int b)
{
    if(a==b)
        return ;
    if(dfn[a]<dfn[b])
    {
        if(bin[b]==1)
        {
            bin[b]=0;
            ans--;
        }
        LCR(a,fa[b]);
    }
    else
    {
        if(bin[a]==1)
        {
            bin[a]=0;
            ans--;
        }
        LCR(fa[a],b);
    }
}
int main()
{
    int m,e,f;
    int cot=1,q;
    while(scanf("%d %d",&n,&m),n+m)
    {
        init();
        ans=0;
        for(int i=0; i<m; i++)
        {
            scanf("%d %d",&e,&f);
            Q[e].push_back(f);
            Q[f].push_back(e);
        }
        tarjin(1,-1);
        scanf("%d",&q);
        printf("Case %d:\n",cot++);
        while(q--)
        {
            scanf("%d %d",&e,&f);
            LCR(e,f);
            printf("%d\n",ans);
        }
    }
    return 0;
}

 

以上是关于(POJ 3694) Network 求桥个数的主要内容,如果未能解决你的问题,请参考以下文章

poj3694(lca + tarjan求桥模板)

[POJ3694]Network(LCA, 割边, 桥)

POJ 3694 Network (tarjan + LCA)

POJ3694 Network(Tarjan双联通分图 LCA 桥)

poj3694 双连通分量+lca

POJ 3694Network(Tarjan边双联通分量 + 缩点 + LCA并查集维护)