HDU 3123-GCC(递推)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 3123-GCC(递推)相关的知识,希望对你有一定的参考价值。

GCC

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3993    Accepted Submission(s): 1304


Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
 

Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.
 

Output
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000
 

Sample Input
1 10 861017
 

Sample Output
593846
求 n!%m=(n-1)!*n%m; 即f(n)=f(n-1)*n%m;
并且 (0!+1!+...n!)%m 假设n>m 那么以后的k!都能够被m整除。。忽略
然后 。。递推就能够了
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <list>
#define ll long long
using namespace std;
const int INF=1<<27;
const int maxn=1010;
int main()
{
	int t;
	char n[200];int m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s %d",n,&m);
		int tem;
		if(strlen(n)>=7)
		tem=999999;
		else
		sscanf(n,"%d",&tem);
		tem=min(m,tem);
		ll f1=1%m,fn,ans=f1;
		for(int i=1;i<=tem;i++)
		{
			fn=f1*i%m;
			ans+=fn;
			f1=fn;
		}
		printf("%lld\n",ans%m);
	}
    return 0;
}


以上是关于HDU 3123-GCC(递推)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 2501 [Tiling_easy version] 递推

HDU 2089 不要62 (递推+暴力)

hdu1078 dp(递推)+搜索

HDU - 2604 Queuing(矩阵快速幂或直接递推)

HDU 5860 Death Sequence (递推)

HDU 2044 一只小蜜蜂...(递推,Fibonacci)