PERMUTATION

Posted JebediahKerman

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PERMUTATION相关的知识,希望对你有一定的参考价值。


DESCRIPTION:
从1到n一共n个数字组成的所有排列中,逆序对个数为k的有多少个。
INPUT:
第一行为一个整数T(<10),以下T 行,每行两个整数n(<1000),k(<1000),意义如题目所述。
OUTPUT:
对每组数据输出答案对10000 取模后的结果
SAMPLE INPUT:
1
4 1
SAMPLE OUTPUT:
3

 

#include<cstdio>
using namespace std;
int main()
{
    freopen("permut.in","r",stdin);
    freopen("permut.out","w",stdout);
    int t(0),n(0),k(0);
    static int f[1001][1001];
    for(int i=0;i<=1000;i++)
        f[i][0]=1;
    for(int i=1;i<=1000;i++)
        for(int j=1;j<=1000;j++)
        {
            if(i>j)f[i][j]=(f[i-1][j]+f[i][j-1])%10000;
            else f[i][j]=(f[i-1][j]+f[i][j-1]-f[i-1][j-i]+10000)%10000;
        }
    scanf("%d",&t);
    while(t)
    {
        t--;
        scanf("%d%d",&n,&k);
        printf("%d\n",f[n][k]);
    }
    return 0;
}

以上是关于PERMUTATION的主要内容,如果未能解决你的问题,请参考以下文章

牛客-火星人——next_permutation运用题

next_permutation 与 prev_permutation(全排列算法)

A - Next_permutation

全排列 next_permutation() 函数的用法

hdu1716(库函数next_permutation)

python中itertools里的product和permutation