A strange lift

Posted 勿忘初心0924

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了A strange lift相关的知识,希望对你有一定的参考价值。

A strange lift

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 941 Accepted Submission(s): 448
 
Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can‘t go up high than N,and can‘t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you‘ll go up to the 4 th floor,and if you press the button "DOWN", the lift can‘t do it, because it can‘t go down to the -2 th floor,as you know ,the -2 th floor isn‘t exist.
Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button "UP" or "DOWN"?
 
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can‘t reach floor B,printf "-1".
 
Sample Input
5 1 5
3 3 1 2 5
0
 
Sample Output
3
 
 
 
Recommend
8600
 
/*
莫名其妙就WA,莫名就AC
*/
#include <bits/stdc++.h>
#define N 205
using namespace std;
int Floor[N];
int visit[N];
int step[N];
int n,A,B;
int bfs()
{
    queue<int> Q;
    Q.push(A);
    visit[A]=1;
    while(!Q.empty())
    {
        int start=Q.front();
        //cout<<start<<endl;
        Q.pop();
        if(start==B)
            return step[B];
        if(start+Floor[start]<=n&&!visit[start+Floor[start]])
        {
            //cout<<"visit[start][0]="<<visit[start][0]<<endl;
            Q.push(start+Floor[start]);
            visit[start+Floor[start]]=1;
            step[start+Floor[start]]=step[start]+1;
        }    
        if(start-Floor[start]>=1&&!visit[start-Floor[start]])
        {
            Q.push(start-Floor[start]);
            visit[start-Floor[start]]=1;
            step[start-Floor[start]]=step[start]+1;    
        }    
    }
    return -1;
}
int main()
{
    //freopen("C:\\Users\\acer\\Desktop\\in.txt","r",stdin);
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(visit,0,sizeof visit);
        memset(step,0,sizeof step);
        scanf("%d%d",&A,&B);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&Floor[i]);
        }    
        printf("%d\n",bfs());
    }
}

 

以上是关于A strange lift的主要内容,如果未能解决你的问题,请参考以下文章

Hdoj 1548.A strange lift 题解

A strange lift_BFS

HDU 1548 A strange lift (暴力搜索)

A strange lift(Dijistra优化)

hdu-1548 A strange lift

HDU 1548 A strange lift