USACO挤牛奶

Posted KYRIE`RUSSAL

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了USACO挤牛奶相关的知识,希望对你有一定的参考价值。

题目描述

三个农民每天清晨5点起床,然后去牛棚给3头牛挤奶。第一个农民在300时刻(从5点开始计时,秒为单位)给他的牛挤奶,一直到1000时刻。第二个农民在700时刻开始,在 1200时刻结束。第三个农民在1500时刻开始2100时刻结束。期间最长的至少有一个农民在挤奶的连续时间为900秒(从300时刻到1200时刻),而最长的无人挤奶的连续时间(从挤奶开始一直到挤奶结束)为300时刻(从1200时刻到1500时刻)。 你的任务是编一个程序,读入一个有N个农民(1 <= N <= 5000)挤N头牛的工作时间列表,计算以下两点(均以秒为单位):
  • 最长至少有一人在挤奶的时间段。
  • 最长的无人挤奶的时间段。

输入

Line 1: 一个整数N。 Lines 2..N+1: 每行两个小于1000000的非负整数,表示一个农民的开始时刻与结束时刻。

输出

一行,两个整数,即题目所要求的两个答案。

样例输入

3 300 1000 700 1200 1500 2100

样例输出

900 300

提示

 

来源

 

[提交][状态][讨论版]

 

 

 

 

复制代码
var
    a,b:array[0..5100] of longint;
    s,t,n,ans1,ans2,i,j:longint;

function max(x,y:longint):longint;
begin
    if x<y then exit(y) else exit(x);
end;

procedure Qsort(x,y:longint);
var mid,i,j,t:longint;
begin
    i:=x; j:=y; mid:=a[(x+y) div 2];
    repeat
        while a[i]<mid do inc(i);
        while a[j]>mid do dec(j);
        if i<=j then
        begin
            t:=a[i]; a[i]:=a[j]; a[j]:=t;
            t:=b[i]; b[i]:=b[j]; b[j]:=t;
            inc(i); dec(j);
        end;
    until i>j;
    if x<j then Qsort(x,j);
    if i<y then Qsort(i,y);
end;

begin
    readln(n);
    for i:=1 to n do read(a[i],b[i]);
    Qsort(1,n);
    ans1:=b[1]-a[1]; s:=a[1]; t:=b[1];
    for i:=2 to n do
    begin
        if b[i]<=t then continue;
        if (b[i]>t)and(a[i]<=t) then
        begin
            ans1:=max(ans1,b[i]-s);
            t:=b[i];
            continue;
        end;
        if a[i]>t then
        begin
            ans2:=max(ans2,a[i]-t);
            s:=a[i]; t:=b[i];
        end;
    end;
    writeln(ans1,\' \',ans2);
end.
复制代码

 

 

 

复制代码
#include<cstdio>
#include<algorithm>
using namespace std;
int a[1000050];
int main(){
    int n,x,y,j,i,x1=0,x2=0,s=1,s2=0,b=1111111111,e=0;
    scanf("%d",&n);
    for(i=0;i<n;i++){
        scanf("%d%d",&x,&y);
        b=min(b,x); e=max(e,y);
        for(j=x;j<y;j++)a[j]=1;
    }
    for(i=b+1;i<=e;i++){
        if(a[i]==1&&a[i-1]==1)s++;
        if(a[i]==0&&a[i-1]==1){x1=max(x1,s);s=0;s2=1;}
        if(a[i]==0&&a[i-1]==0)s2++;
        if(a[i]==1&&a[i-1]==0){x2=max(x2,s2);s2=0;s=1;}
    }
    printf("%d %d\\n",x1,x2);
    return 0;
}

以上是关于USACO挤牛奶的主要内容,如果未能解决你的问题,请参考以下文章

USACO挤牛奶

题解Luogu P1204 [USACO1.2]挤牛奶Milking Cows

[USACO1.2]挤牛奶Milking Cows

洛谷—— P1204 [USACO1.2]挤牛奶Milking Cows

codevs——1385 挤牛奶

P3093 [USACO13DEC]牛奶调度Milk Scheduling - 贪心+二叉堆