POJ1961[KMP 失配函数]

Posted Candy?

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ1961[KMP 失配函数]相关的知识,希望对你有一定的参考价值。

Period
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 16776   Accepted: 8077

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source


求每个前缀的最短循环节

错位的部分是个循环节
即i%(i-f[i])==0
 
再次想想从0开始问题 
 
跳到的那个位置之前的所有字符与当前失配字母前的相同数量个字母是相匹配的
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e6+5;
int n,f[N];
char p[N];
int main(){
    int cas=0;
    while(scanf("%d",&n)!=EOF&&n){
        scanf("%s",p);
        f[0]=f[1]=0;
        for(int i=1;i<n;i++){
            int j=f[i];
            while(j&&p[j]!=p[i]) j=f[j];
            f[i+1]=p[j]==p[i]?j+1:0;
        }
        printf("Test case #%d\n",++cas);
        for(int i=2;i<=n;i++)
            if(f[i]>0&&i%(i-f[i])==0) printf("%d %d\n",i,i/(i-f[i]));
        printf("\n");
    }
}

 

以上是关于POJ1961[KMP 失配函数]的主要内容,如果未能解决你的问题,请参考以下文章

POJ2406Power Strings[KMP 失配函数]

poj1961(kmp算法next数组应用)

poj1961 Period(KMP)

POJ1961最短周期串/最大周期 kmp

POJ3461-KMP算法

poj1961 Period kmp解决找字符串的最小循环节