POJ3461 Oulipo[KMP]

Posted Candy?

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ3461 Oulipo[KMP]相关的知识,希望对你有一定的参考价值。

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 36916   Accepted: 14904

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘‘B‘‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source


KMP裸题 出现几次
 
关于KMP
字符串从0开始,所以p[i]就是地i+1个字符
f[i]是失配函数,表示已经匹配了i个字符,i+1(就是p[i])失配转移到哪里
令j=f[i],就是说以位置i-1结尾的后缀包括了0...j-1这个前缀,再检查p[j]==s[i](即j+1  i+1)
 
//
//  main.cpp
//  poj3461
//
//  Created by Candy on 10/19/16.
//  Copyright © 2016 Candy. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=1e6+5,M=1e4+5;
int T,f[M];// already i(0...i-1),now pos i
char s[N],p[M];
void getFail(){
    size_t m=strlen(p);
    f[0]=f[1]=0;
    for(int i=1;i<m;i++){
        int j=f[i];
        while(j&&p[i]!=p[j]) j=f[j];
        f[i+1]=p[i]==p[j]?j+1:0;
    }
}
int kmp(){
    getFail();
    int cnt=0;
    size_t n=strlen(s),m=strlen(p);
    int j=0;
    for(int i=0;i<n;i++){
        while(j&&s[i]!=p[j]) j=f[j];
        if(s[i]==p[j]) j++;
        if(j==m) cnt++;
    }
    return cnt;
}
int main(int argc, const char * argv[]) {
    scanf("%d",&T);
    while(T--){
        scanf("%s%s",p,s);
        printf("%d\n",kmp());
    }
    
    return 0;
}

 

 

以上是关于POJ3461 Oulipo[KMP]的主要内容,如果未能解决你的问题,请参考以下文章

poj 3461 - Oulipo 经典kmp算法问题

POJ 3461 Oulipo KMP算法题解

poj 3461 Oulipo(KMP)

POJ3461 Oulipo[KMP]

POJ 题目3461 Oulipo(KMP)

POJ3461 Oulipo[KMP]学习笔记