每日一九度之 题目1083:特殊乘法

Posted Asimple

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了每日一九度之 题目1083:特殊乘法相关的知识,希望对你有一定的参考价值。

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:5319

解决:3606

题目描述:

写个算法,对2个小于1000000000的输入,求结果。

特殊乘法举例:123 * 45 = 1*4 +1*5 +2*4 +2*5 +3*4+3*5

输入:

 两个小于1000000000的数

输出:

 输入可能有多组数据,对于每一组数据,输出Input中的两个数按照题目要求的方法进行运算后得到的结果。

样例输入:
123 45
样例输出:
54

按题目直接模拟就好。

//Asimple
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cctype>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <set>
#include <map>
#include <string>
#include <queue>
#include <limits.h>
#define INF 0x7fffffff
using namespace std;
const int maxn = 55;
typedef long long ll;
ll sum = 0;
char s1[maxn], s2[maxn];
 
int main(){
    while( ~scanf("%s %s",s1, s2) ){
        sum =0;
        for(int i=0; s1[i]!=\0; i++){
            for(int j=0; s2[j]!=\0; j++){
                sum += (s1[i]-0)*(s2[j]-0);
            }
        }
        printf("%ld\n",sum);
    }
    return 0;
}

 

以上是关于每日一九度之 题目1083:特殊乘法的主要内容,如果未能解决你的问题,请参考以下文章

每日一九度之 题目1041:Simple Sorting

每日一九度之 题目1038:Sum of Factorials

每日一九度之 题目1089:数字反转

每日一九度之 题目1084:整数拆分

每日一九度之 题目1023:EXCEL排序

每日一九度之 题目1063:整数和